13

I have a very large tex file and a very large bib file. When I run (xelatex, bibtex) I get several warnings like this:

Database file #1: Thesis.bib
Warning--I didn't find a database entry for "Jag08"
Warning--I didn't find a database entry for "Jag08"
Warning--I didn't find a database entry for "Aharonian2005c"
Warning--I didn't find a database entry for "Marandon2008f"

The problem is that those entries are there in the bib file.

EDIT: Jag08 is actually the first entry. And some later entries in the bib file work without a problem. And in the tex file, most earlier and later citations work as well.

I have therefore created a minimal example (all files are always in the same directory): tex:

\documentclass{book}
\usepackage{natbib}
\begin{document}
Test citation: \citep{Jag08}
\bibliographystyle{plainnat}
\bibliography{mytestbiblio}
\end{document}

and bib:

@article{Jag08,
   author = {{de Jager}, O.~C. and {Djannati-Ata{\"i}}, A.},
    title = "{Implications of H.E.S.S. observations of pulsar wind nebulae}",
  journal = {ArXiv e-prints},
archivePrefix = "arXiv",
   eprint = {0803.0116},
 keywords = {Astrophysics},
     year = 2008,
    month = mar,
   adsurl = {http://adsabs.harvard.edu/abs/2008arXiv0803.0116D},
  adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}

But when I run this example, everything works as expected (note that Jag08 is exactly the entry that makes the first problems in the large file).

So my question would be: What in your experience could cause these problems? I can neither post the whole files nor expect you to solve this, therefore I'm merely looking for directions of likely causes of this error.

  • 3
    Maybe a missing bracket } that eats the following entries? I would divide the .bib file and smaller segments and try that one after another to see where the problem is. – Andy Nov 2 '11 at 8:10
  • where is the mytestbiblio.bib saved? In the documents directory? – user2478 Nov 2 '11 at 8:31
  • yes all files are in the same directory – xubuntix Nov 2 '11 at 8:37
10

To answer my own question:

After I replaced:

regime \citep[][]{Jager2008}.

with:

regime \citep[][]{Jager2008}.

everything works without problems.

Note: I can not see any difference, but the new command was copied from a different location in the latex file (I also copy&pasted the new and old version in here...). This behaviour is reproducable, that means if I click 'undo' and then run again, the same warnings appear again...

| improve this answer | |
  • 1
    The citation in your question was Jag08 not Jager2008 – Seamus Nov 2 '11 at 10:07
  • 1
    True, I had changed that in the meantime in one of my attempts to fix the problem... – xubuntix Nov 2 '11 at 10:19
  • 3
    There maybe some invisible characters from copy and paste. Load the document into a hexcode viewer, then you'll see it – user2478 Nov 2 '11 at 10:24
  • 1
    No invisible characters in the lines posted though. – Thomas Ahle Apr 29 '16 at 16:41
  • I confirm that invisible characters are an issue (and likely culprit). I was going nuts, and reading this suggestion from @Herbert solved it. Thanks! – Pascal Romon Aug 22 '17 at 10:46
1

Having encountered the same warning, your answers didn't work but I managed to resolve the issue by using a shorter file-name for the ".bib"-file. So instead of using "langer marsch durch die institutionen.bib" I put "marsch.bib" and the warnings disappeared.

| improve this answer | |
  • 5
    Welcome to TeX.sx! If I were to guess than not the length of your file name was a problem but the fact that it contained spaces. – cgnieder May 24 '14 at 16:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.