4

Using Win 10 and Lyx 2.2

Tried to view the Beamer manual as PDF but the error comes up "the external program pdflatex finished with an error"

I have tried to view the Latex log under the Document menu and have only found warnings:

Package hyperref Warning: Option `pdfauthor' has already been used,

LaTeX Font Warning: Font shape `T1/cmss/m/n' in size <4> not available

LaTeX Font Warning: Size substitutions with differences

and underneath these warnings lyx appears to have either disregarded or found solutions.

Looking through the other questions, I have tried the suggestion to use Sumatra as my default PDF viewer, and have altered the viewer and Path settings accordingly. This allowed me to view the Introduction which came with Lyx but I've still not been able to view the Beamer manual.

I have also been unable to view/export to PDF any of the Beamer examples or templates which came with Lyx.

Is this a problem with pdflatex or Beamer?

Is there a way to fix this?

My alternative is to use Powerpoint but that is not what I had in mind.

Edit: I tried XeTeX with the same errors produced, but managed to get things working with LuaTex. Any ideas as to what's going on?

LuaTex is now no longer working either, and all I did was view 2 more beamer files.

  • Welcome to TeX.SX! What you report are normal warnings that can safely be ignored. Maybe there's some real error message below them – egreg Oct 15 '16 at 13:48
  • I couldn't see anything obvious or flagged as an error, unless this is one: Underfull \vbox (badness 10000) has occurred while \output is active [] – Michael Ramage Oct 15 '16 at 13:53
  • Do you get an error from a simple "hello world" document? If not, then try to narrow down the beamer manual until you figure out what exactly cause the preview not to work. This can take some time. – scottkosty Oct 15 '16 at 14:21
  • Might try this: Instead of compiling from within Lyx, use Windows command box, and issue the pdflatex command (with path) from there. It might possibly show Windows errors that Lyx or the log don't show. – user103221 Oct 15 '16 at 14:57
1

I had the same issue. I have windows 10 installed , and also have lyx along with Miktex 2.9 . This problem was because of this reason that Lyx is 32 bit software , and the Miktex I installed was 64 bit version , I un-installed Miktex 64 bit version , and installed 32 bit verion of miktex , and the problem gone... Hence You must have Miktex and LyX both installed in x86 i.e 32 bit versions. Thanks ..

|improve this answer|||||
1

Reinstalling Lyx bundle with deleting the preferancies from previous version helped me. Then tools->reconfigure launch was needed for some reason. Now my .lyx files are compiled normally. I also didn't let Miktex to install updates, but it seems this is not so important as the substituting of the preferencies and reconfiguration.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.