2

I downloaded a Brazilian Portuguese dictionary from WinEdT with file name br. Its properties box says it is a "Text Document (.dic)", which may help below but i do not know.

I placed it in a file folder called br in C:\Program Files\WinEdt Team\WinEdt 9\Dict

WinEdT Help gives clearly written instructions, which do not actually say what to do. They say several times:

When you select the Dictionary Manager branch in the Options Interface, the toolbar in that interface contains a button that allows you to start the Dictionary Manager dialog.

Nothing at all like the dialogue box shown in WinEdt Help opened but I was taken to a file called Dictionaries.ini where i saw

[BUILD]

DICTIONARY=""
  FILE=""
  ENABLED=1
  MODE_FILTER=""
  LOAD_ON_START=1
  SAVE_ON_EXIT=1
  ADD_NEW_WORDS=0
  USE_FOR_COMPLETION=1
  ALLOW_COMPOUNDED_WORDS=1

REQUIRES=20100208

I filled it in this way:

[BUILD]

DICTIONARY="brazil"
  FILE="C:\Program Files\WinEdt Team\WinEdt 9\Dict\br"
  ENABLED=1
  MODE_FILTER=""
  LOAD_ON_START=1
  SAVE_ON_EXIT=1
  ADD_NEW_WORDS=0
  USE_FOR_COMPLETION=1
  ALLOW_COMPOUNDED_WORDS=1

REQUIRES=20100208 

That may not be what they wanted, but I do not know what they wanted.

That part of code still reads that way now. But nothing I can do (including restarting WinEdT ) makes it spell check source files in Portuguese.

What should I have done?

4

The problem is that you have put your dictionary definition before the line

[DICTIONARIES]

in the file Dictionaries.ini, so when the relative configuration section has not started yet.

Putting the lines

DICTIONARY="brazil"
  FILE="%B\Dict\br.dic"
  ENABLED=1
  MODE_FILTER=""
  LOAD_ON_START=1
  SAVE_ON_EXIT=1
  ADD_NEW_WORDS=0
  USE_FOR_COMPLETION=1
  ALLOW_COMPOUNDED_WORDS=1

after the above line and then pressing Shift+Ctrl+F9 to reload the file will work.


Alternatively, if you don't want to do all the work yourself, revert the changes and let the macro InstallDict from winedt.org do it for you. It suffices to follow the instructions and it will install the dictionary for you!

  • P.S.: be sure that you've downloaded the unicode version of the dictionary.... – karlkoeller Oct 18 '16 at 16:35
  • That sounds right. But when I hit <kbd>Shift+Ctrl+F9</kbd> I get "Initialization Error! (long name of file) unrecognized keyword." – Colin McLarty Oct 18 '16 at 16:53
  • I forgot to change the line FILE=..... Now should be OK. – karlkoeller Oct 18 '16 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.