0

I have a general question regarding citing in footnotes and the formatting. In some cases the page number is separated from the "p." when there is not enough space and latex forces a wordwrap. So "author (year), p." are on one line and the page number on the following line. Would a "protected blank" be a solution to this problem?

4
  • 1
    There are hardspaces ~ and thin spaces \, that should not break at linebreaks. – Steven B. Segletes Oct 18 '16 at 13:21
  • Yes and in fact it's the default with biblatex. (Do you really use biblatex as your tagging suggests? For more detailed help an MWE would help.) – moewe Oct 18 '16 at 13:21
  • I use biblatex / biber. So there is not an option in a package that I can use? – TRJW Oct 18 '16 at 14:08
  • moewe was right. This is the default with biblatex. I made a mistake - I put a "p." in the squared brackets so that biblatex did not insert the "p." by itself. – TRJW Oct 18 '16 at 15:33
3

If you write \cite[12]{sigfridsson} biblatex does all the things for you. It inserts the command \ppspace between the automatically inserted "p." and the "12". By default \ppspace is \addnbspace (a non-breaking space), so you won't get a line break there.

If you use another citation package that does not do this sort of thing automatically for you, consider just using ~: \cite[p.~12]{sigfridsson}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.