1

I am writing a paper that uses the sansmathfonts package, and I am trying to upload it to the arXiv. Unfortunately, this runs me into the error

LaTeX Error: This NFSS system isn't set up properly.

and no pdf file is produced on the remote compile (though it compiles perfectly well on my machine). I gather from this question that this is probably due to lacking fonts on the arXiv system, but that's not something I can control.

What additional files should I upload with my submission to get rid of this problem? Or is this simply not something I'll be able to do?


Edit: here's a MWE as far as I can tell

\documentclass{article}
\usepackage{sansmathfonts}
\begin{document}

\sffamily
Some math: $a=b$, and $\omega = \Delta+ \varepsilon$.

\end{document}

I'm not sure whether the errors this gets on the remote compile are exactly comparable, but in any case this compiles locally and fails on the arXiv build. In particular, if I upload the document above as test.tex along with the sansmathfonts.sty file, the arXiv returns the following log file:

[verbose]: Creating arXiv submission AutoTeX object
[verbose]: Calling arXiv submission AutoTeX process
[verbose]: TeX/AutoTeX.pm: admin_timeout = minion
[verbose]: <test.tex>   is of type 'LATEX2e'.
[verbose]: <sansmathfonts.sty>  is of type 'TeX auxiliary'.
[verbose]: ~~~~~~~~~~~ Processing file 'test.tex'
[verbose]: TEXMFCNF is unset.
[verbose]: ~~~~~~~~~~~ Running hlatex for the first time ~~~~~~~~
[verbose]: Running: "(export HOME=/tmp PATH=/texlive/2011/bin/arch:/bin; cd /submissions/1697443/ && latex 'test.tex' < /dev/null)" 2>&1
[verbose]: This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
rman-x-2011-07-01, ngerman-x-2011-07-01, afrikaans, ancientgreek, ibycus, arabi
c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
h, french, galician, german, ngerman, swissgerman, monogreek, greek, hungarian,
icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, marathi, or
iya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, kurmanji,
lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, pol
ish, portuguese, romanian, russian, sanskrit, serbian, serbianc, slovak, sloven
ian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, welsh, loaded
.
(/texlive/2011/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/texlive/2011/texmf-dist/tex/latex/base/size10.clo)) (./sansmathfonts.sty)
(/texlive/2011/texmf-dist/tex/latex/hyperref/hyperref.sty
(/texlive/2011/texmf-dist/tex/generic/oberdiek/hobsub-hyperref.sty
(/texlive/2011/texmf-dist/tex/generic/oberdiek/hobsub-generic.sty))
(/texlive/2011/texmf-dist/tex/latex/graphics/keyval.sty)
(/texlive/2011/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
(/texlive/2011/texmf-dist/tex/latex/oberdiek/kvoptions.sty)
(/texlive/2011/texmf-dist/tex/latex/hyperref/pd1enc.def)
(/texlive/2011/texmf-config/tex/latex/latexconfig/hyperref.cfg)
(/texlive/2011/texmf-dist/tex/latex/url/url.sty))

Package hyperref Message: Driver (default): hdvips.

(/texlive/2011/texmf-dist/tex/latex/hyperref/hdvips.def
(/texlive/2011/texmf-dist/tex/latex/hyperref/pdfmark.def
(/texlive/2011/texmf-dist/tex/latex/oberdiek/rerunfilecheck.sty)))
No file test.aux.
No file OMLcmssm.fd.

! LaTeX Error: This NFSS system isn't set up properly.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
... 

l.7 \begin{document}

? 
! Emergency stop.
... 

l.7 \begin{document}

No pages of output.
Transcript written on test.log.

Similarly, I tried uploading those two files along with all the .fd files in the sansmathfonts folder, which also fails, with some extra error messages in the log file:

[verbose]: Creating arXiv submission AutoTeX object
[verbose]: Calling arXiv submission AutoTeX process
[verbose]: TeX/AutoTeX.pm: admin_timeout = minion
[verbose]: <ot1xcmss.fd>    is of type 'unknown'.
[verbose]: <ussmsa.fd>  is of type 'unknown'.
[verbose]: <omlcmssm.fd>    is of type 'unknown'.
[verbose]: <ot1cmsmf.fd>    is of type 'unknown'.
[verbose]: <omscmsssy.fd>   is of type 'unknown'.
[verbose]: <test.tex>   is of type 'LATEX2e'.
[verbose]: <uxcmss.fd>  is of type 'unknown'.
[verbose]: <omxcmssex.fd>   is of type 'unknown'.
[verbose]: <ussesint.fd>    is of type 'unknown'.
[verbose]: <ucmsmf.fd>  is of type 'unknown'.
[verbose]: <t1xcmss.fd> is of type 'unknown'.
[verbose]: <ussmsb.fd>  is of type 'unknown'.
[verbose]: <sansmathfonts.sty>  is of type 'TeX auxiliary'.
[verbose]: ~~~~~~~~~~~ Processing file 'test.tex'
[verbose]: TEXMFCNF is unset.
[verbose]: ~~~~~~~~~~~ Running hlatex for the first time ~~~~~~~~
[verbose]: Running: "(export HOME=/tmp PATH=/texlive/2011/bin/arch:/bin; cd /submissions/1697443/ && latex 'test.tex' < /dev/null)" 2>&1
[verbose]: This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
rman-x-2011-07-01, ngerman-x-2011-07-01, afrikaans, ancientgreek, ibycus, arabi
c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
h, french, galician, german, ngerman, swissgerman, monogreek, greek, hungarian,
icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, marathi, or
iya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, kurmanji,
lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, pol
ish, portuguese, romanian, russian, sanskrit, serbian, serbianc, slovak, sloven
ian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, welsh, loaded
.
(/texlive/2011/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/texlive/2011/texmf-dist/tex/latex/base/size10.clo))
(/texlive/2011/texmf-dist/tex/latex/lm/lmodern.sty) (./sansmathfonts.sty)
(/texlive/2011/texmf-dist/tex/latex/hyperref/hyperref.sty
(/texlive/2011/texmf-dist/tex/generic/oberdiek/hobsub-hyperref.sty
(/texlive/2011/texmf-dist/tex/generic/oberdiek/hobsub-generic.sty))
(/texlive/2011/texmf-dist/tex/latex/graphics/keyval.sty)
(/texlive/2011/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
(/texlive/2011/texmf-dist/tex/latex/oberdiek/kvoptions.sty)
(/texlive/2011/texmf-dist/tex/latex/hyperref/pd1enc.def)
(/texlive/2011/texmf-config/tex/latex/latexconfig/hyperref.cfg)
(/texlive/2011/texmf-dist/tex/latex/url/url.sty))

Package hyperref Message: Driver (default): hdvips.

(/texlive/2011/texmf-dist/tex/latex/hyperref/hdvips.def
(/texlive/2011/texmf-dist/tex/latex/hyperref/pdfmark.def
(/texlive/2011/texmf-dist/tex/latex/oberdiek/rerunfilecheck.sty)))
No file test.aux.
(./omlcmssm.fd) (./omscmsssy.fd) (./omxcmssex.fd) (./uxcmss.fd)
(/texlive/2011/texmf-dist/tex/latex/lm/ot1lmr.fd)
(/texlive/2011/texmf-dist/tex/latex/hyperref/nameref.sty
(/texlive/2011/texmf-dist/tex/generic/oberdiek/gettitlestring.sty))

Package hyperref Warning: Rerun to get /PageLabels entry.

(./ot1xcmss.fd) (./ot1cmsmf.fd)
kpathsea: Running mktextfm cmsmf10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input cmsmf10
This is METAFONT, Version 2.718281 (TeX Live 2011)

kpathsea: Running mktexmf cmsmf10

! I can't find file `cmsmf10'.
<*> ...=ljfour; mag:=1; nonstopmode; input cmsmf10

Please type another input file name
! Emergency stop.
<*> ...=ljfour; mag:=1; nonstopmode; input cmsmf10

Transcript written on mfput.log.
grep: cmsmf10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input cmsmf10' failed.
kpathsea: Appending font creation commands to missfont.log.

! Font OT1/cmsmf/m/n/10=cmsmf10 at 10.0pt not loadable: Metric (TFM) file not f
ound.
<to be read again> 
relax 
l.12 Some math: $a
=b$, and $\omega = \Delta+ \varepsilon$.
? 
! Emergency stop.
<to be read again> 
relax 
l.12 Some math: $a
=b$, and $\omega = \Delta+ \varepsilon$.
No pages of output.
Transcript written on test.log.
9
  • 1
    I'm not sure arXiv uses the most recent TeX distribution. If something font related fails, just give up and use standard fonts. – egreg Oct 18 '16 at 17:17
  • @egreg Happy to, if there is a way to get sans-serif math using standard fonts that doesn't break my document. (I should add here that this is the single one of >5 tries from questions on this site that didn't look horrendous.) – E.P. Oct 18 '16 at 17:18
  • there are two error messages with that line what is the help text from h or that follows , should be either The system maintainer forgot to specify a suitable substitution or For encoding scheme ...the defaults ... do not form a valid font shape – David Carlisle Oct 18 '16 at 17:59
  • 1
    No, not at a computer at the moment. I'd go with egreg, if it is not supported by arxiv, then don't fit it. See it in the same way as journals do not let you decide the fonts used in your contribution to their journal. Plus, latex might not even be able to use the fonts that way, and it might end up difficult for others to download your tex file from arxiv and compile it. – daleif Oct 24 '16 at 9:04
  • 2
    That is not latexs decision, it is more likely a conscious decision made by arxiv. I have been on the receiving end of what authors do, not always pretty – daleif Oct 24 '16 at 9:34
1

You can use the cmbright package. It was available with TeXLive 2011 (and much earlier).

For more options see also http://www.tug.org/pracjourn/2006-1/hartke/hartke.pdf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.