1

I'm new using TeXstudio and I'm trying to cite the references in my work. But unfortunately I had an error says:

Process started: bibtex build/"bibliographyCitation"

I couldn't open file name `build/bibliographyCitation.aux'

Process exited normally

I searched about solutions for this problem but no one specify how can I know the default folder that has the .aux file? and how can I change it step by step?!

This is the current settings I have: TeXstudio Settings

Thank you

  • At the line BibTeX, write: bibtex % instead of bibtex build/%. – ebosi Oct 19 '16 at 7:46
  • @ebo I did and still have [?] instead of the citation :( – F 505 Oct 19 '16 at 8:14
  • Your problem is then solved (-; ! Have a look here. I suggest you to take some time to browse some introduction to LaTeX (e.g. the (not) so short one): it's worth the time/effort invested in it! – ebosi Oct 19 '16 at 8:18
4

The theory

In your settings, the bash command associated with BibTeX is: bibtex build/%. It means: "look for the (implicitely said .aux) file in following folder: <location of the .tex file you're compiling>/build".
This is handy when you tell (pdf)LaTeX to put every temporary/auxiliary files in a subfolder (here name build) in order to keep the original folder "clean". You activate this behavior using the -output-directory option while running (pdf)LaTeX (e.g., pdflatex -output-directory=build/ %.tex).

Your case

However, since you did not enabled this feature (i.e., the bash command used for (pdf)LaTeX compiling does not call the -output-directory option), all temp files are created in the same folder than the .tex file you are compiling.
But in your case, bibtex is still looking for the .aux-file in a non-existing subfolder named build: bibtex build/%.

The solution

Thus, you should tell bibtex to look for the .aux file in the same folder than your .tex file, i.e. write bibtex % instead of bibtex build/% at the BibTeX line.
(Or you could also create a subfolder named build, and use following commands: pdfLaTeX: pdflatex -output-directory=build/ %.tex; bibTeX: bibtex build/%. But you would also need to update paths for other commands (e.g. pdf-viewer).)

  • I tried the two options and the last option I tried is : 4shared.com/photo/u2IPH1cNba/18-01-38_11-20-39_AM.html – F 505 Oct 19 '16 at 8:28
  • And here is what I got : 4shared.com/photo/UxwVet0_ba/18-01-38_11-20-18_AM.html – F 505 Oct 19 '16 at 8:30
  • As detailed in the "What to do" section of the selected answer of the linked question (see comment above), you need to compile your document as following: pdflatex, bibtex, pdflatex, pdflatex (some explanations here). Your issue is thus now likely due to insufficient number of compilation of your document. In other word, try running pdflatex twice. – ebosi Oct 19 '16 at 8:38
  • sadly no :( I decided to leave the whole application and use MS with endnote to do the bibliography:( It's not what I want but I did that just to gain time because it's easy to use but not efficient output as TeXstudio. Definitely I will try later to solve it:( – F 505 Oct 22 '16 at 15:25
  • sadly no :( I decided to leave the whole application and use MS with endnote to do the bibliography:( It's not what I want but I did that just to gain time because it's easy to use but not efficient output as TeXstudio. Definitely I will try later to solve it:( – F 505 Oct 22 '16 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.