0

I am using LyX on an Arch Linux system. I am trying to use LyX with biber

I just installed biber, it wasn't available from PATH (located at /usr/bin/vendor_perl) but it now is, i.e.

 which biber

gives:

/usr/bin/vendor_perl/biber

and biber works from the command line. Unfortunately LyX refuses to recognise biber. I ran reconfigure and I even reinstalled LyX.

I also tried setting it up as a custom processor but this gives the output:

biber exited with code 127

Any ideas how to fix this?

2
  • 1
    Did you by chance start LyX from the GUI? Start LyX from the comman-line and then your path should be the same as when you did which biber. If this is indeed the case, then let us know and we can tell you how to set the environment such that your GUI also recognizes your new PATH. – scottkosty Oct 19 '16 at 20:37
  • Indeed, that worked perfectly. Thanks a million. I pasted the command line output here: gist.github.com/bquast/ecef4ff105a22942f60484e64ab7e547 – Bastiaan Quast Oct 21 '16 at 9:37
2

The problem is that the PATH from your terminal can be different from the PATH of other applications. For example, if you change the PATH in your .bashrc, then that will affect your terminal but not necessarily applications you start from the GUI.

One way to change the PATH system-wide (i.e. in a central location that affects the PATH of most processes) is to set the PATH to what you want in /etc/environment. After changing it there, restart your computer and reconfigure LyX.

2
  • any chance you could give an example line to be added? In my case biber is in /usr/bin/vendor_perl/ – Bastiaan Quast Oct 21 '16 at 9:41
  • Sure, put something like PATH="/usr/bin/vendor_perl/:/opt/texbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games" – scottkosty Oct 21 '16 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.