7

I have this document that used to compile fine until a couple of weeks ago, but now I'm getting:

! Package caption Error: For a successful cooperation we need at least     version
(caption)                `2004/02/13 v1.2' of package listings,
(caption)                but only version
(caption)                `2002/04/01 1.0 (Carsten Heinz)'
(caption)                is available.

See the caption package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.6 \begin{document}

? 
! Undefined control sequence.
<argument> ...t@title \endgroup }\newcaptionstyle 
                                                  {lsttitle}    {\caption@make {...
l.6 \begin{document}

us problem, so I'm exiting ...
***? 

So I guess I have to install a newer version of listings? How can I?

  • Better to update your TeX installation as a whole. Things do depend on each other and you can't generally expect a newer version of a package to work with an older version of another package. Often it does work, but it is much better to update everything altogether. – cfr Oct 20 '16 at 23:45
  • How can I do that? I tried this and this and this and still get the same error. – Raphael Oct 21 '16 at 1:12
  • As noted above, it is a bad idea to upgrade one package alone. But if you must: Go to the CTAN.org web site, and locate the listings package. Download its files. As superuser (sudo) use those files to replace the ones already in your installation. If that fails, then use Ubuntu's package manager to re-install the original. – user103221 Oct 21 '16 at 1:36
  • Never mind, I did get to reinstall Latex now by doing sudo apt-get remove texlive, sudo apt-get autoremove, sudo apt-get remove tex-common and then sudo apt-get install texlive texlive-latex-extra texlive-lang-portuguese, but now I get ! LaTeX Error: File 'abntex2.cls' not found. This is from a package that was supposed to be installed automatically with TeX Live. – Raphael Oct 21 '16 at 1:51
  • Okay, I got this last error solved by installing texlive-full, but the listings error is still here. – Raphael Oct 21 '16 at 2:10
10

Finally solved. I came across this bug report, which gave me the idea on what to do: I unistalled the package fp-utils-3.0.0 and Latex is working just fine again.

  • 1
    Thanks! Not sure how I would figured this out on my own :) – Michael Mior Jul 28 '17 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.