5

I am trying to insert a footnote at the end of my sentence using \footnote{some text}, however, when I compile the file, I see [?] instead of the footnote. I am using aps template in revtex4-1. Any help would be appreciated.

  • Are you running latex bibtex latex latex? – Dai Bowen Oct 23 '16 at 23:48
  • I fear I do not know the answer. I am using Texmaker if that helps! Im sorry I just started using LaTex. – Ptheguy Oct 23 '16 at 23:51
  • Try pressing F6 F11 F6 F6, does that display anything? Alternatively try adding the nofootinbib and repeatedly compiling. Both should show something. – Dai Bowen Oct 23 '16 at 23:53
  • Pressing F11 says "This is BibTex" – Ptheguy Oct 23 '16 at 23:54
8

By default revtex places footnotes in the bibliography (see e.g. How to refer to same footnote twice in REVTeX?) - in order to make them appear you therefore need to run bibtex in the normal fashion (even if you have no actual citations and no proper bibliography) as described in Question mark or bold citation key instead of citation number.

Alternatively you can disable the normal behaviour of revtex by using the class option nofootinbib. Apply this class option and you should be able to simply run latex repeatedly to generate a standard bottom of page footnote.

  • Thank you so much. May I ask how you apply nofootinbib? – Ptheguy Oct 23 '16 at 23:59
  • 1
    It's an option to the revtex class, i.e.\documentclass[nofootinbib]{revtex4-1} – Dai Bowen Oct 24 '16 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.