0

I'm writing my thesis using the classicthesis package and ran into a problem with a longtable that is wider than my textwidth. I tried the last few hours, but couldn't find any solution.

Using LTleft I can only make it work on odd or even pages, but not on both.

\blindtext[3]

%\setlength\LTleft{0cm}
%\setlength\LTright{0cm}
\begin{longtable}{|p{0.6cm}|p{1.9cm}|p{2.3cm}|p{1.8cm}|p{2.7cm}|p{2.5cm}|}
\hline
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
    1 & Text & Text & Text & Text & Text \\
\end{longtable}

And this is how it looks like:enter image description here enter image description here

How can I set the even margin without reset the odd margin?

Any help is appreciated.

  • Welcome to TeX.SE. If I understand your write-up, you basically have a table that's much too wide for the text block. (The classicthesis package is known for imposing a fairly low value for \textwidth.) Are you at all considering "slimming down" the longtable? – Mico Oct 24 '16 at 18:44
  • 2
    why do you use a minipage inside a p column? a p is alreay a parbox which is almost the same code as minipage? the best solution would be to reduce the column widths so it fits, perhaps that is not possible, hard to tell as your sample text is just Text – David Carlisle Oct 24 '16 at 18:54
  • the Minipage was not necessary for the example, but even beside that and using p, it does not work. And unfortunately I cannot reduce the with of the columns, due to its content. Edit: I removed the minipage from the question. – user2274386 Oct 24 '16 at 19:35
  • You appear to have a pair of mutually incompatible requirements: (a) too many, fixed-width columns and (b) a fairly narrow text block (courtesy of the classicthesis package). I guess reducing the font size (and reducing the column widths after all) and/or reducing the value of \tabcolsep (the parameter that governs the amount of whitespace to the left and right of each column) are the only options you're left with. – Mico Oct 24 '16 at 20:39
  • If I stay on one page and use addmargin with table and tabularx or with longtable it works, but if I have a page break it went wrong. Do I have any chance by using a table with a manual page break? (But what I don't want is that two tabels appear in my toc) – user2274386 Oct 25 '16 at 7:48
1

It has been some time, but have you tried to put before the table (this worked in my case, I hade all the below setup in geometry, so I basically copied it and set everything as necessary):

\clearpage
\newgeometry{margin=1cm,inner=1cm,outer=1cm,marginparwidth=0cm,marginparsep=0mm}

and after the table

\clearpage
\restoregeometry

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.