3

Some unintended action of mine caused the style of the source to change to one with a dark background. How do I restore the TexShop default?

1

If you open the TeXShop preferences pane, the top right settings on the first panel will allow you to set the text and background colours. Click on each coloured rectangle to choose the colours you want. The left hand rectangle sets the text colour, and the right hand one, the background colour.

The defaults are to have text black and background white, as in the image below.

TeXShop preferences

  • I think he wanted the defaults, not something else. – David Spivak Oct 2 '18 at 13:31
  • @DavidSpivak I'm not sure what the point of your comment is, but I've indicated what the default setting is. – Alan Munn Oct 2 '18 at 17:42
0

Open a terminal and do this:

defaults delete TeXShop foreground_R
defaults delete TeXShop foreground_G
defaults delete TeXShop foreground_B
defaults delete TeXShop background_R
defaults delete TeXShop background_G 
defaults delete TeXShop background_B
  • Seems like a lot of work compared to using the preference pane though. :) – Alan Munn Oct 2 '18 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.