1

When I build the output, I can view it in pdf using sumatrapdf by pressing F5 sometimes, but most of the time I have to rebuild the output until it works. The error is:

enter image description here

When I build the pdf, I can open the pdf using SumatraPDF by going to the folder and opening it, but I would prefer to be able to do it by pressing F5.

I am using the following settings:

enter image description here

enter image description here

There are some lines that run past the picture; here they are:

Command line arguments to pass to the compiler:

-synctex=-1 -max-print-line=120 -interaction=nonstopmode "%wm"

Executable path (Viewer tab, first line)

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

(These are the same settings (including file paths, which I think are correct because that is where I find the executables in the folders) as in Configure TeXnic Center with Sumatra for the viewer tab and the same settings as suggested in How to configure TeXnicCenter 2.0 with Sumatra (2013--2016 version) for the (La)TeX tab)

What can I do to fix this, or is there any more information I should provide?

1

In your third image you showed that your configuration is missing something. The command for the "view project's outputs" has to be:

[DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]

Please see the following image from my profile (in german, but you can see easily where you have to change it ...):

enter image description here

  • I did as you indicated but it did not work for me :( – Herman Jaramillo Feb 23 '18 at 16:48
  • It did not work in my case too. The issue remains the same. – Antonio Sesto Oct 24 '18 at 9:29
0

After having the same problem and finding this post, my issues were eventually solved by the solution posted here: https://tex.stackexchange.com/a/199646, i.e. adding the command --synctex=1 in the (La)Tex Command line arguments to pass to the compiler.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.