I'm trying to use \bibliographystyle{unsrt} to sort my bibliography in order of appearance. From here I know that I can't mix the biblatex package with \bibliographystyle. However, when I remove biblatex another compile error arises on a different line.

Here's what I have tried...



\title{ Machine Learning for 3D Segmentation }
\author{Kendall Weihe}
\date{October 27, 2016}



It throws an error at the line \DeclareLanguageMapping{british}{british-apa}

  • Of course, if you remove biblatex, \DeclareLanguageMapping{british}{british-apa} is not defined, nor \addbibresource nor \printbibliographyIf you want the equivalent of the unsrt` bib style, load biblatex with the [sorting=none] option. `
    – Bernard
    Oct 27, 2016 at 18:27
  • 2
    If you want to use biblatex, remove \bibliographystyle{unsrt} and load biblatex with the sorting=none option: \usepackage[backend=biber,style=numeric,sorting=none]{biblatex}. Note that \DeclareLanguageMapping{british}{british-apa} is only necessary (and should probably only be used) with style=apa.
    – moewe
    Oct 27, 2016 at 22:03
  • Any news here? Did you try the suggestions?
    – moewe
    Oct 31, 2016 at 17:28
  • yes, sorry forgot about this. @moewe suggestion worked, thanks! feel free to write an answer Nov 2, 2016 at 1:23

1 Answer 1


You cannot mix BibTeX and biblatex.

In your code remove \bibliographystyle{unsrt} (which is BibTeX language) and load biblatex with sorting=none


You will probably not need \DeclareLanguageMapping{british}{british-apa}, which is only necessary if you use the biblatex-apa style.

  • I did it but just label names are showed now. I compile bunch of times but still like that. Jun 6, 2018 at 8:00
  • @ömerkoçhan Please consider asking a new question with an MWE/MWEB, a description of what you are doing, what errors or warnings you get and what the output looks like.
    – moewe
    Jun 6, 2018 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .