0

Using a valid myrefs.bib in the path, I tried the following minimal examples (two of which are commented)

\setupbibtex[database=myrefs]
\starttext
\completepublications
%\completepublications[criterium=all] 
%\placepublications[criterium=all] 
\stoptext

This example produces an empty pdf, context seems to choke on the two others when I uncomment (one at a time)

regarding the version number:

version as given at end of man context: version 0.60 01-01-2015 mtx-context(1)

output of context --version:

mtx-context     | ConTeXt Process Management 0.61
mtx-context     |
mtx-context     | main context file: /usr/share/texmf/tex/context/base/context.mkiv
mtx-context     | current version: 2015.05.18 12:26

And from last .log

open source     > 1 > 1 > /usr/share/texmf/tex/context/base/cont-yes.mkiv
ConTeXt  ver: 2015.05.18 12:26 MKIV current  fmt: 2016.7.5  int: english/english

To the content of my database: my .bib file is rather long, here first and last entries (this short .bib file also fails):

% IMPORTANT: The following is UTF-8 encoded.  This means that in the presence
% of non-ASCII characters, it will not work with BibTeX 0.99 or older.
% Instead, you should use an up-to-date BibTeX implementation like “bibtex8” or
% “biber”.

@ARTICLE{Kampmann:966,
      author       = {Kampmann, R and Deriglazov, V and Haese-Seiller, M and
                      Marmotti, M and Tristl, M and Sackmann, E},
      title        = {{REFSANS}: a novel reflectometer for analyses of liquid and
                      soft surfaces at the new research reactor {FRM}-{II} in
                      {M}unich/{G}ermany},
      journal      = {Physica / B},
      volume       = {276-278},
      issn         = {0921-4526},
      address      = {Amsterdam},
      publisher    = {North-Holland Physics Publ.},
      pages        = {212-213},
      year         = {2000},
      ddc          = {530},
      cid          = {I:(DE-MLZ)4109},
      experiment   = {EXP:(DE-MLZ)REFSANS-20140101},
      typ          = {PUB:(DE-HGF)16},
      UT           = {WOS:000086413000088},
      doi          = {10.1016/S0921-4526(99)01294-6},
      url          = {https://impulse.mlz-garching.de/record/966},
}

@ARTICLE{Hexemer:174106,
      author       = {Hexemer, Alexander and Müller-Buschbaum, Peter},
      title        = {{A}dvanced grazing-incidence techniques for modern
                      soft-matter materials analysis},
      journal      = {IUCrJ},
      volume       = {2},
      number       = {1},
      issn         = {2052-2525},
      address      = {Chester},
      publisher    = {International Union of Crystallography (IUCr)},
      reportid     = {IMPULSE-2016-00077},
      pages        = {106 - 125},
      year         = {2015},
      ddc          = {530},
      cid          = {I:(DE-MLZ)4109 / I:(DE-MLZ)4024 / I:(DE-MLZ)4058},
      experiment   = {EXP:(DE-MLZ)REFSANS-20140101},
      typ          = {PUB:(DE-HGF)16},
      doi          = {10.1107/S2052252514024178},
      url          = {https://impulse.mlz-garching.de/record/174106},
}
  • It would help a lot if you showed the contents of myrefs. Also I think you mean \setupbibtex[database=myrefs.bib] (Note the .bib extension). – Henri Menke Oct 28 '16 at 6:55
  • 2
    The extension is not needed. – Thomas Oct 28 '16 at 7:05
  • As I said in my answer: bibliography is an area under development. Your version is from texlive 2015. You should upgrade to something newer. Since many linux distributions are woefully late with their tex packages, your safest bet is to install a ConTeXt standalone (which can easily coexist with other tex installations, if this is a concern for you). Running the example with your bib file, I get correct output both from the version in texlive 2016 (2016.05.17) and the current beta version (2016.10.25). – Thomas Oct 28 '16 at 10:11
1

Which version are you running? This code gives the expected result for me:

\setupbibtex [database=mytest.bib]

\starttext

\placepublications [criterium=all]

\stoptext

Or, if you want to use the new interface (which is still in development and doesn't have proper documentation yet):

\usebtxdataset [default] [mytest.bib]

\starttext

\placelistofpublications [default] [method=dataset]

\stoptext

Both files typeset the entire bib file. If you use the new method, you should see a message like

 publications    > adding bib data to set 'default' from source 'mytest.bib'

in your log file to show that your bib file has been found and could be loaded/

  • The new interface is still kind of under development as there are some rough edges and extensibility is a problem but it is not at all improperly documented: pragma-ade.nl/general/manuals/mkiv-publications.pdf – Henri Menke Oct 27 '16 at 19:25
  • I am using 0.60. I tried the second code... same nothing as a result. No errors but just a one page pdf with title "References" – Jean-Francois Moulin Oct 27 '16 at 20:40
  • 1
    What does context --version print? 0.60 is not a meaningful version number. – Thomas Oct 27 '16 at 21:21
  • @Henri Menke: you've made your point clear in the comment. I disagree, and I'm certain even Alan, who is writing the documentation, would disagree: it's not finished, and it is massively incomplete. I don't see any necessity for you to edit my answer to reflect your point of view. – Thomas Oct 28 '16 at 7:04
  • I edited my question to provide complete version info and my bib file – Jean-Francois Moulin Oct 28 '16 at 8:08
0

After a lot of experimentation, including upgrading TeXLive, I eventually removed all of my LaTeX and ConTeX installation, and reinstalled ConTeX. The short bib worked. So initial problem solved, but it seems I really needed a clean install.

For the record, running on my full bib file led to (excerpt):

....
close source    > 3 > 9 > testbibtex.bbl
publications    > placing all entries, use 'text' to be more selective

tex error       > tex error on line 36 in file testbibtex.tex: ! Misplaced alignment tab character &

<recently read> &

\@@pb@journal ->Nuclear Instruments $\&
                                   $ Methods in Physics Research A

So I simply removed the offending $&$ (which seemed ok for LaTeX!), and my whole bibliography came out perfectly typeset.

  • In any case, why use $\&$ in math mode? Simply using \& should have worked. – Aditya Oct 31 '16 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.