0

I'm using biber to make my first bibliography and I'm running into lots of problems, most of them are solved but I can't fix this one. I continuously get an error message : Missing '$' inserted, on the line right after \printbibliography Here's a sample from my bibliography, everything except the inproceedings is a similar online reference:

@online{FC,
    title = "Flight Controllers : The Processor Behind Every Multirotor Flight",
    author = "Clym Montgomery",
    year = "2014",
    url = {http://www.tomshardware.com/reviews/multi-rotor-quadcopter-fpv,3828-2.html},
    note = "Accessed : October 27 2016"
}

@inproceedings{PID_algorithm,
    title = "A Fractional Order PID Tuning Algorithm for A Class of Fractional Order Plants",
    author = "Chunna Zhao and Dingyiu Xue and YanQuan Chen",
    year = "2005",
    booktitle = "International Conference on Mechatronics and Automation",
}

I'm using biber and I haven't defined a style, AFAIK I'm not supposed to/don't have to when using biber. Do I have to escape certain characters that I'm not escaping, or is something else wrong? I've found other questions solved because you don't need to escape the underscores.

edit : Just this bib entry :

@online{blheli_s,
    title = "BLHeli_s - Smooth as Silk",
    year = "2016",
    url = {https://www.rcgroups.com/forums/showthread.php?t=2640796},
    note = "Accessed : October 27 2016"
}

still raises the error (after deleting the bib database and rerunning latexmk)

  • I see nothing that could raise the error. The usual suspects are URLs with underscore. Try isolating the bad entry. – egreg Oct 27 '16 at 17:21
  • I do have other url's with underscores. Is there a way to comment out in the .bib file to make my life easier? – Brydon Gibson Oct 27 '16 at 17:23
1

It was the underscore in BLHeli_S - I was too focused on the url's that I didn't look at the suspect title of the article.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.