I started writing a book last year with

  • "TexLive 2015"
  • my literature managed by "biber"
  • own biblio files bbx and cbx
  • "Texmaker" as editor

and everything worked smoothly.

As my old computer started having some troubles, I bought a new one and installed "TexLive 2016" from scratch on it, copied the biblio files (bbx anx cbx) to the respective folders as where they were before and made any settings in "Texmaker" analoguous to what I had on the old computer.

However when I try to compile my book.tex file, it ends up in error messages saying that my bibio files are not found.

A rearch in the forums revealed that "TechLive 2016" is incompatible with biber 2.6. So I tried removing biber 2.6 and replaced it by biber 2.4, but the errors remain unchanged.

Currently, I'm totally lost and afraid, that all the weeks of work on my book is doomed.

Could anyone give me please some information how I can get this software back to work? As I am a newbie, a more detailed description of a remedy is highly appreciated.

Thanks in advance.



Further information:

Here the detailed version of what I did:

  1. Installation of Linux Mint 18, 64 Bit, Mate on a blank harddisk.
  2. Download of texlive2016-20160523.iso and extraction of that file into a new folder texlive.
  3. In that folder texlive sudo ./install-tl -gui and installation of TexLive 2016.
  4. In terminal environment variable adjusted: PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH
  5. In terminal normal user (Oli) endued with rights: sudo chown -hR Oli /usr/local/texlive/2016
  6. In terminal TexLive Manager started with tlmgr gui and complete update of TexLive (around 375 packages were updated).
  7. Copy of my biblio files iest_neu.bbx and iest_neu.cbx from my old computer to the two folders where they used to be, which are /usr/local/texlive/texmf-local/tex/latex/biblatex-iest and a hidden folder in my home folder ~/.texmf/tex/latex/biblatex-iest (ownerships and flags of the copied files were checked for correctness).
  8. In the editor Texmaker adaption of the preferences analoguously to what they looked like on my old computer, which relates to only three settings: a) the PdfLaTex path was set to /usr/local/texlive/2016/bin/x86_64-linux/pdflatex, b) the Bib(la)tex entry to biber %, and c) in the quick compilation settings, the radio button was set to the second position.

When I compile my book.tex file on the old computer, it runs through smoothly. The same tex file on the new computer yields many error messages, of which two principles are identified:

  1. File: /usr/local/texlive/2016/texmf-dist/tex/latex/biblatex/biblatex.sty, Type: Error, Lines: 13001 and 13002, Message: ! Package biblatex Error: Style 'iest_neu' not found. See the biblatex package docu... enter image description here
  2. File: /usr/local/texlive/2016/texmf-dist/tex/latex/biblatex/biblatex.sty, Type: Error, Many lines..., Message: ! Package biblatex Error: Command '\cite' undefined. See the biblatex package docu... enter image description here

As proposed, I tried to locate my biblio files by kpsewhich. For that, an additional installation of package texlive-binaries was necessary. However when I searched for my biblio files iest_neu.bbx and iest_neu.cbx, as well as for the file biblatex-examples.bib, kpsewhich neither gives an output, nor an error message. Nonetheless, when I look for these files in Midnight Commander, I truly find them (my biblio files iest_neu.bbx and iest_neu.cbx at the places already mentioned above and the file biblatex-examples.bib in the folders /usr/local/texlive/2016/texmf-dist/doc/latex/biblatex/examples and /usr/local/texlive/2016/texmf-dist/bibtex/bib/biblatex).

The attempted removal and reinstallation of biblatex in tlmgr gui fails. The logfile outputs this: enter image description here


Finally, I found the solution to my problems by myself. For the scenario

Texlive 2016 + biber 2.6 + TexMaker 4.4.1 + own biblio files (*.bbx and *.cbx)

I state that in contrast to Texlive 2016 + biber 2.4 the following changes need to be done - otherwise your tex files will fail to compile:

  • your own biblio files need to be in your home directory in a visible folder ~/texmf/tex/latex/ (formerly, it was possible to put them in a hidden folder)
  • in the preferences for Bib(la)tex in TexMaker, you need to indicate the full path like that "/usr/local/texlive/2016/bin/x86_64-linux/biber" % (formerly, it was sufficient to write biber % there)

Best regards,


closed as off-topic by cfr, Zarko, Stefan Pinnow, Heiko Oberdiek, user36296 Nov 6 '16 at 15:09

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    1. Don't panic. 2. biber 2.6 is compatible with texlive 2016, reinstall it. 3. It could be that you will have to adapt your own bbx and cbx-files to the newest biblatex version. But as you didn't say what errors you get, didn't show your files and didn't show a minimal example it is not possible to say more. – Ulrike Fischer Oct 28 '16 at 22:08
  • 1
    Not finding files is usually a different problem than finding the files, but thinking there's a version mis-match. If you are worried about the finding problem, try kpsewhich myfile.bbx (if looking for myfile.bbx); is the file found? If not, try kpsewhich biblatex-examples.bib; is that file found? If kpsewhich is finding things, then maybe the editor you are using is involved in the problem. If things aren't being found, then that's the first issue to sort out. Please update your question once you have sorted out whether things are being found or not. – jon Oct 28 '16 at 22:14
  • 1
    Where did you put the files? – Herb Schulz Oct 28 '16 at 22:43
  • 1
    Sounds like something is messed up. I would deinstall biblatex with the package manager and reinstall it using the package manager. And place the IEST files in the same directory as the book source. – Johannes_B Oct 29 '16 at 12:15
  • 4
    I'm voting to close this question as off-topic because it has been resolved in comments, albeit possibly by means which are far from recommended on the basis of information which is less than accurate .... – cfr Nov 6 '16 at 12:38