I need to compile between two and four times before I see changes I make in the editor (TeXstudio) and each time I compile, a new .tex file is created with random letters and numbers at the end.

For example, If I create the file hello.tex and compile two to four times I'll get the file,


then I make some small changes in the editor and compile two to four times I'll get the additional file,


After continuing to do this (each time compiling between two to four times before I see the changes I made), I now have many files that look like

hello.tex.QU6664, hello.tex.Ak6664, hello.tex.YX6664, hello.tex.sN6664, hello.tex.Ss6664, ...

A little bit of additional information (in case it's relevant): Everything was working fine up until a few days ago, i.e. only needed to compile once and only the file hello.tex was created. I still only get one .aux, .synctex and .pdf files. I use TeXstudio to write and compile. I don't think it has anything to do with the bibliography (I tried removing bibliography altogether and still having the same problem).

How do I prevent these additional files from appearing and only compiling once like I used to? Has anyone had a similar problem?

  • 2
    Something changed. You did the change. Track the change. Without knowing what is inside those weird auxiliary files, how are we supposed to help? The psychic squad is currently on vacation.
    – Johannes_B
    Commented Oct 29, 2016 at 11:15
  • @Johannes_B The changes I make are in texstudio. Say a sentence was "hello there" and then I change it to "hello there sir" then the above will happen.
    – user103828
    Commented Oct 29, 2016 at 11:17
  • 5
    Okay. I figured out what's causing the problem - Dropbox. When I copied the files onto my desktop then it worked fine.... I think the reason is that I went over my space capacity and although I've now deleted files to have additional space, it might take dropbox a few days to update.... thanks for all the help and sorry it was an irrelevant (and / or stupid and / or unclear) question!
    – user103828
    Commented Oct 29, 2016 at 12:42
  • 6
    You should post your solution as an answer to your own (not stupid) question, and put "dropbox" into the title and fix the tags. Someone else might run into the same problem and find the solution here. Commented Oct 29, 2016 at 13:01
  • 1
    @user103828 I edited your question a bit in order to make it more easily findable and more helpful for users with the same problem, even though it might not exactly match your problem/perception of the problem anymore; hope you don’t mind. Among other things, I removed the bit about the .ent file – these are usually generated by the package endnotes, see e.g. this list.
    – doncherry
    Commented Oct 31, 2016 at 10:32

3 Answers 3


I have the same problem. According to the bug report, it seems to be related to a change in the way TeXstudio saves a file. What can you do? Two options:

a) Give up the cloud

... and simply work outside your Dropbox, as the OP suggested. You can still manually copy files into the Dropbox to back them up or share them.

b) Downgrade TeXstudio and keep the cloud

My (hopefully just temporary) solution: Downgrade to TeXstudio 2.10.8, which saves files the old way. I’m using the portable version in order to be able to run it alongside the current one.

Transferring your settings to the portable version is really easy: Find the settings file texstudio.ini and copy it to the directory of the portable version. (TeXstudio needs to be closed while you do that.) I’m not sure if you also need to import the .txsprofile file, if somebody can clarify that, let me know!

  • Thanks for the answer. Until the bug is fixed (hopefully soon), I think I'll just work on my desktop and copy the files into dropbox at the end of the day!
    – user103828
    Commented Oct 30, 2016 at 7:50
  • @user103828 That works as well, of course, if you don’t need/want the convenient ongoing cloud-backup, I’ll add that to the answer
    – doncherry
    Commented Oct 30, 2016 at 16:25

Dropbox was creating these additional files (not sure exactly why) due to space capacity constraints. Small files were not causing any issues. Everything works fine on my desktop. Although I now have enough capacity on dropbox, I think it takes dropbox a few days to update.


  • It turns out that this is a texstudio bug and not a problem with dropbox (and that my solution is incorrect) - see @UlrikeFischer link in the comments below.

  • I plan to just work on my desktop anyway and copy files to dropbox at the end of the day until the bug is fixed (hopefully soon). Alternatively, I'm sure @doncherry solution also works.

Edit2: I stopped working on the desktop and downgraded texstudio like @doncherry suggested.


Version 2.12.0 has solved the issue. The changelog file includes the line

TeXstudio 2.12.0
- revert to pre 2.11.0 save method on Windows because the new QSaveFile has problems with Dropbox folders

I have checked and it does work for me on Windows 10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .