3

This question already has an answer here:

I have to prepare a document with the following criteria - 1.5 spacing, text in Times New Roman, Size 12 (with footnotes throughout in Calibri, Size 10). Since I'm using luaLaTeX to get the fonts I'm not sure if the change font of footnote answers apply. In my MWE I am able to get the times font and have the 1.5 line spacing but how can I set the footnote font to size 10 and Calibri?

\documentclass[12pt,a4paper,onecolumn]{article}
\usepackage[margin=1.5in,footskip=0.25in]{geometry}
\usepackage{fontspec}
\usepackage{microtype}
\setmainfont{times}
%\setmainfont{Calibri}
\usepackage{titling}
\setlength{\droptitle}{-2cm}
\usepackage [autostyle=once,english=british]{csquotes}
\usepackage [UKenglish,american,british]{babel}
\usepackage[notes, backend=biber, includeall=false,]{biblatex-chicago}

\usepackage{setspace}
%\doublespacing
\onehalfspacing

\begin{document}

This is test.\footnote{Test footnote.}

\end{document}

marked as duplicate by gman, Community Oct 31 '16 at 13:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

Good news: The method mentioned in the link you've provided is fully applicable to your document as well. :-)

By the way, since your main document font size is 12pt, \footnotesize works out to be 10pt -- exactly what you need.

enter image description here

\documentclass[12pt,a4paper,onecolumn]{article}
\usepackage[margin=1.5in,footskip=0.25in]{geometry}
\usepackage{fontspec}
\usepackage{microtype}
\setmainfont{Times New Roman} % or: 'XITS', which is a Times Roman clone
\setsansfont{Calibri}
\usepackage{titling}
\setlength{\droptitle}{-2cm}
\usepackage [autostyle=once,english=british]{csquotes}
\usepackage [UKenglish,american,british]{babel}
\usepackage[notes, backend=biber, includeall=false,]{biblatex-chicago}

\usepackage{setspace}
%\doublespacing
%\onehalfspacing
\setstretch{1.5}

%% See http://tex.stackexchange.com/a/4781/5001 for the following code:
\usepackage{etoolbox}
\makeatletter
\patchcmd{\@footnotetext}{\footnotesize}{\footnotesize\sffamily}{}{}
\makeatother

\setlength\textheight{3cm} % just for this example

\begin{document}
This is test.\footnote{Test footnote.}
\end{document}
  • Given the question and the answer, isn't that a duplicate? – Johannes_B Oct 30 '16 at 8:15
  • @Johannes_B - It would appear (to me at least) that there was a second issue in the new posting: How to enable a particular sans-serif font? I handled this issue in my answer by changing \setmainfont{Calibri} to \setsansfont{Calibri}. Admittedly, not a particularly difficult thing to do... – Mico Oct 30 '16 at 8:19
  • I think we could close more questions as duplicates. But those tiny little things making a question unique ... Honestly, it bothers me a bit. – Johannes_B Oct 30 '16 at 8:30
  • @Johannes_B - Has this been raised/discussed/decided on Meta? – Mico Oct 30 '16 at 8:31
  • 1
    @gman How to get Calibri Italic is a completely different question and unrelated to footnotes, or bibliographies. – Johannes_B Oct 31 '16 at 12:27
1

Following a crude hack. Patching the font change directly into the footnotetext might be cleaner.

gmanFontFootnotes

\documentclass[12pt,a4paper,onecolumn]{article}
\usepackage[margin=1.5in,footskip=0.25in]{geometry}
\usepackage{fontspec}
\usepackage{microtype}
\setmainfont{Linux Libertine O}
%\setmainfont{Calibri}
\usepackage{titling}
\setlength{\droptitle}{-2cm}
\usepackage [autostyle=once,english=british]{csquotes}
\usepackage [UKenglish,american,british]{babel}

\usepackage{setspace}
%\doublespacing
\onehalfspacing

\let\oldfootnote\footnote
\renewcommand{\footnote}[1]{\oldfootnote{\fontspec{TeX Gyre Chorus}#1}}
\begin{document}

This is test.\footnote{Test footnote.}

\end{document}

Not the answer you're looking for? Browse other questions tagged or ask your own question.