1

I just updated MiKTeX (64bit, Win7) today and encountered the error that the new biblatex 3.6 and the older biber 2.5 don't match (they both came with my fresh MiKTeX 2.9 installation this morning). I've tried several approaches, including

  1. downgrading biblatex to 3.5 (doesn't work for me),
  2. installing biber in cygwin (doesn't work for me either -- cygwin still has the old biber 2.5 in its mirrors). I ended up with
  3. downloading biber 2.6 windows binaries from sourceforge, which finally worked.

I needed to use this version: https://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/current/binaries/Windows/biber-MSWIN64.zip

I renamed it bibernew.exe and put it into my miktex installation here: C:\Program Files\MiKTeX 2.9\miktex\bin\x64

I still have to figure out how to tell arara to use it. Is there a better way to deal with this version incompatibility?

Cheers,

Monika

closed as off-topic by moewe, user13907, Zarko, barbara beeton, Maarten Dhondt Nov 18 '16 at 19:10

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Interesting, we had a recent post about the same How to Downgrade Biblatex the OP there appeared to uninstall and reinstall biber I assume through the MiKTeX Package Manager and this resolved their problem. Updating MiKTeX should be the only fix you need, you may also wish to try synchronizing through the Package Manager. Regarding your first approach biblatex 3.5 and 3.6 both require biber 2.6 (you can check the compatibility of biblatex and biber versions in Table 1 of the biblatex manual). – Dai Bowen Nov 4 '16 at 12:04
  • 1
    The present version of biber for MiKTeX is 2.6 (packaged on 9/13/2016). Didn't you update? – Bernard Nov 4 '16 at 13:21
  • As far as I am aware, MikTeX's Biber packages were not touched by the package refactoring action. And MikTeX seems to have Biber 2.6 (from 2016-09-13) already, indeed on my MikTeX installation I have Biber 2.6. You may have to update your TeX distribution using the User and Admin Update Manager (maybe even twice). – moewe Nov 4 '16 at 16:22
  • Note that the versions of biblatex and Biber that MikTeX ships should always match. The only problem you may run into is that you either do only a partial update (i.e. you update only selected packages) or that you have install one of the two relevant packages as User and the other as Admin in which case the two are managed by different Package Managers and Updaters. To be sure always run both the User and Admin Updater when you do an update. – moewe Nov 4 '16 at 16:31
  • 4
    I'm voting to close this question as off-topic because it is about a version mismatch between biblatex and Biber that can be solved by updating the packages involved properly. – moewe Nov 18 '16 at 17:50