0

I would like to ask if anyone has encountered and, hopefully, defeated the issue i am struggling with. Let me give an illustrative example. I am using latest MacOS and mactex with texshop in version 3.73.

I do the following:

  1. I create a file (TeXshop: File->New) with random name (say aaa.tex) I save it on the Desktop: /Users//Desktop under name aaa.tex.
  2. I type content, say "Hello word". And press Cmd+S to save the file. I quit the TeXshop
  3. I open this file again with TeXshop and I am able to edit the file, them press Cmd+s to save changes,
  4. when I quit texshop I get asked if I want to save unsaved changes (despite just pressing Cmd+S). If I click "save" the changes are indeed saved.

It seems however the Cmd+S I have pressed in step 3 is silently ignored (the alert in step 4 should not be required right after pressing Cmd+S) and this is verified by the way the "File" menu look like (Save option is grayed out). It seems that "Save" option is unavailable when the file is opened, however it is there for freshly created files, until the TeXshop is closed.

file menu, with "Save" option inactive

I do not think this is permissions error (mises is my username):

-rw-r--r--@ 1 mises  staff  18 Nov  6 16:42 aaa.tex

EDIT I think that everntual conflict of key bindings (which I believe does not exist, as Cmd+S works in every other application) is not really an issue, as the "save" option is grayed out in the menu, so even doing save with a mouse is not an option.

EDIT2 I have attempted reinstall, and this behaviour persists at least starting from 3.70.

EDIT3 "Save" is grayed out, even if file has been changed (and editor asks for saving unsaved changes when quit is attempted).

EDIT4 General Tab in Preferences shown below general tab in preferences

  • What are your settings in the General tab of System Preferences? Also what version of the OS are you using? Finally, at least for now, do you have any key bindings set for TeXShop in the Keyboard->Shortcuts->App Shortcuts of System Preferences? Did you have a file open and changes made to it when you took that shot of the menu above. – Herb Schulz Nov 6 '16 at 16:45
  • @Herb Schultz. In the picture pasted above it is clear that the cmd+S is associated with "Save". The "Save option is grayed out also in the menu, so Cmd+S cannot really work as it triggers an inactive option. But I cannot understand why it is inactive. – Lacek Nov 6 '16 at 16:49
  • @Lacek if there is no file open and changed it will be grayed out. I asked about above. – Herb Schulz Nov 6 '16 at 16:57
  • @HerbSchults. So this is how the menu looks like when the file IS open. – Lacek Nov 6 '16 at 17:01
  • @Lacek did you change anything in the file before displaying this menu? If the file is open but nothing has changed there is nothing to Save. Also, please answer the rest of my inquiry to help diagnose the problem. Needless to say I have no problem at this end. – Herb Schulz Nov 6 '16 at 21:04
1

I just spoke with the author of TeXShop and he suggests that you have AutoSave turned off. You can turn it back on using

defaults write TeXShop AutoSaveEnabled YES

to restore it. Also, search for AUTOSAVE in the Help->TeXShop Help Panel… for information about how AutoSave works but note that some of that description is different in recent versions of macOS; e.g., picking up previous versions of a document is under the File->Revert Menu.

  • I am afraid it does not change anything. Just to make sure: I am able to save a file, but with "Save as" (which requires confirming that I want to overwrite the file etc). With "Save" it does nothing, and the option in menu remains grayed out. – Lacek Nov 10 '16 at 9:14
  • The problem is that the normal File menu shows Duplicate…' rather than Save As…' (at least in the English localization) and the only ways I know of to have `Save As…' show is to redefine the some keyboard shortcuts or turn off AutoSave. I suggest you get in touch with the author of TeXShop directly; look under the Extras tab at the TeXShop web site, <pages.uoregon.edu/koch/texshop/index.html>. – Herb Schulz Nov 10 '16 at 12:42
  • Ok, thanks. This problem is getting increasingly interesting... – Lacek Nov 10 '16 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.