1

Compiling the example document below by means of XeLaTeX of a portable MiKTeX 2.9 installation on Win 7 resulted in the following error message: "Unfortunately, the package miktex-xetex-base could not be installed.Please check the log file: F:/MiKTeXPortable/miktex/log/xelatex.log"

In between, the autoinstaller wants to install "fonts\misc\xetex\fontmapping\tex-text.tec" , obviously unsuccessfully.

My understanding is, according to the information given on MiKTeX' homepage ("November package refactoring"), that miktex-xetex-base has been removed and replaced by miktex-xetex and xetex packages, respectively?

Can anybody confirm this and provide (possibly) a solution?

\documentclass[11pt,a4paper]{dinbrief}
\usepackage{xltxtra}
\usepackage{fontspec}
\defaultfontfeatures{Ligatures=TeX, Mapping=tex-text} 
\setmainfont{Calibri} 
\usepackage[ngerman]{babel}
\usepackage{graphicx}
\usepackage{textcomp}
\usepackage{url}

\setromanfont{Calibri}
\setsansfont{Arial}

\setlength{\parskip}{\medskipamount}
\setlength{\parindent}{0pt}
\makeatletter 

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
\newcommand{\areacode}{}

\makeatother %% changes the catcode of @ back to 12

\address{}                     %% Kopfzeile

\signature{M. Mueller}       %% Name des Autors

\backaddress{M. Mueller, Musterweg 17, 99290 Musterstadt}
\nowindowrules                 %% Adressfensterrahmen abschalten

\renewcommand\enclname{Anlagen:}        %% Anlagenbezeichner

\pagestyle{headings} %seitenzahlen der Folgeseiten werden in Kopfzeile gedruckt

\begin{document}
 \setaddressheight {4cm}        %% Höhe des Adressfensters
 \begin{letter}{Bank AG \& Co. KGaA\\Holzweg\\10000 Musterdorf}
 \centeraddress                 %% Empfängeradresse vertikal zentrieren 

%\handling{Eilt/Persönlich}
%%%%%% Bezugszeichenzeile nach DIN 676 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\yourmail{} 
\sign{Kd.-Nr. 1000}

\writer{} %Name des Sachbearbeiters
\renewcommand{\areacode}{01234}
\phone{\areacode}{123456}
\subject{\textbf{Kündigung}\\Konto-Nr. \textbf{1000}}
\opening{Sehr geehrte Damen und Herren,}
   Text
\closing{Mit freundlichen Grüßen}
\end{letter}
\end{document}

\endinput

closed as off-topic by Stefan Pinnow, Zarko, moewe, Mico, user36296 Nov 6 '16 at 22:06

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you install via the Package Manager? – Dai Bowen Nov 6 '16 at 19:03
  • 1
    Sounds as if your local package database is not in sync with the online database. Go to the package manager and synchronize. – Ulrike Fischer Nov 6 '16 at 19:03
  • OK, got it: Syncronizing with the online DB solved the issue. Thanks a lot. – tfran Nov 6 '16 at 19:34
  • @tfran It looks like you've got two separate accounts, tfran and tfran. The Stack Exchange staff can merge them together for you so you can edit all your past questions, as well as properly collect reputation and interact with the site. – Dai Bowen Nov 6 '16 at 20:15
  • 4
    I'm voting to close this question as off-topic because it was solved in the comments. – Stefan Pinnow Nov 6 '16 at 20:50

Browse other questions tagged or ask your own question.