9

Every time I try to synchronize my packages, I'm told the remote package repository is outdated. I've tried this with three remote repositories, and always get the same message. Anybody have any idea what's wrong?

Error message below:

MiKTeX Problem Report Message: The remote package repository is outdated. You have to choose another repository.

Data: url="http://ftp.math.purdue.edu/mirrors/ctan.org/systems/win32/miktex/tm/packages/" Source: Libraries\MiKTeX\PackageManager\RestRemoteService.cpp Line: 275 MiKTeX: 2.9 OS: Windows 7

  • Same problem here, I tried about 10 repositories. The problem started after updating MikTex produced an error. – Sander Heinsalu Nov 7 '16 at 4:52
  • 1
    I'd check this myself, but not on Windows today. Faint possibility: Since Daylight Savings Time just changed in most of the USA, maybe the US repositories have a time problem? Does the error happen if you try a repository elsewhere? – user103221 Nov 7 '16 at 5:00
  • Reported on sourceforge sourceforge.net/p/miktex/bugs/2544 looks to be international – Dai Bowen Nov 7 '16 at 9:54
  • Same problem with ftp.heanet.ie (MikTeX 2.9, 64-bit, Windows 10). – GeMir Aug 11 '17 at 8:35
  • Me and many of my acquaintances and colleagues experience this issue. No solution, except for reinstalling, seems to work – Rubi Shnol Jan 10 '18 at 10:09
9

It seems to be a bug on the timestamping or authentication token of the repository in the Windows registry. I have found that removing the full HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MiKTeX.org\MiKTeX\2.9\MPM registry key and retrying will fix it.

  • Can you really be confident deleting registry keys won't cause other problems? – Dai Bowen Nov 7 '16 at 9:55
  • The keys are re-created by the MikTeX tools if they are missing. – pbk Nov 7 '16 at 13:52
  • I simply waited a day and now the problem is gone. – Ulrike Fischer Nov 7 '16 at 22:44
  • 1
    Doesn't work for me. – GeMir Aug 11 '17 at 8:36
  • 1
    Doesn't work for me either. – ptrcao Jan 10 '18 at 8:40
1

Same problem on Windows 10 solved likes this:

  1. Remove all MikTex entries from the registry.
  2. Delete the MikTeX 2.9 folder from c:\Program Files.
  3. Delete the MikTeX 2.9 folder from c:\users...\AppData\Roaming folder.
  4. Run the installer and chose not to automatically download missing packages.

The last step means that TexWorks will stop at every missing package. Then you close TexWorks, open MikTeX Package Manager, add the package, close the Package Manager, start TexWorks and try again.

Maybe the problem began when I tried to update the installation as suggested on the download web page. Anyway, I have not tried to update my installation and it runs fine.

0

It appears this was a bug that has been fixed. I've been able to update everything today. Thanks to whoever fixed this bug!

https://sourceforge.net/p/miktex/bugs/2544/

  • MiKTeX bugs are reported at GitHub now. This issue is located at github.com/MiKTeX/miktex/issues/27. It's actually closed, but not solved! – Twonky Jan 9 '18 at 8:28
  • I still have this problem with the current release, months on. How can this be allowed to stand considering how many rely on it? – ptrcao Jan 10 '18 at 8:41
  • Closed??? Are you kidding? – Rubi Shnol Jan 10 '18 at 11:43

protected by Community Oct 30 '17 at 13:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.