15

I am a new user of latex. The command \subsection is working i.e. it shows me that this heading is subheading of previous heading with number like 1.1. But \subsubsection is not showing any number, I suppose it should show number like 1.1.1 . but it does not show at all any number.

What could be the issue?

3
  • 1
    There is actually no issue: it is working how it is supposed to work - that it "print section titles with number and subsection without. It's the default settings. If you want the subsection to be numbered, tell it to LaTeX with following command: \setcounter{secnumdepth}{3}
    – ebosi
    Commented Nov 8, 2016 at 12:03
  • 3
    Please always post code examples. In most classes macros like \section and friends are only numbered down to a certain depth. You are not giving us any information about the class you are using (hence the comment at the beginning), you could try to enable it via \setcounter{secnumdepth}{3}
    – daleif
    Commented Nov 8, 2016 at 12:07
  • 1
    Plus, this is a LaTeX matter, it has nothing to do with texniccenter, which is just a tool to make the code that is being processed by LaTeX
    – daleif
    Commented Nov 8, 2016 at 12:08

2 Answers 2

20

I'm guessing that your document class is either report, book, scrreprt, or scrbook -- or a document class that's based on one of these four classes. These document classes have the following setting in common:

\setcounter{secnumdepth}{2}

It implies that level-0 (chapter), level-1 (section), and level-2 (subsection) headings are numbered by default, whereas level-3 (subsubsection) headings and higher-level headings (e.g., paragraph and subparagraph) are not numbered.

If you want level-3 headings to be numbered as well, you need to issue the following instruction in the preamble:

\setcounter{secnumdepth}{3}

Aside: the article and scrartcl document classes, which do not feature level-0 (chapter) headers, have the following setting in common: \setcounter{secnumdepth}{3}. For the memoir document class, which provides level(-2) [!] headers, the default setting is \setcounter{secnumdepth}{1}.

0

Note that if you set:

\setcounter{secnumdepth}{4}

any occurrence of \paragraph will also be numbered. If you also want to appear these numbered sections in your table of contents, do:

\setcounter{tocdepth}{4}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .