3

I recently installed WinEdt 10 and use SumatraPDF.

With SyncTeX switch --synctex=1 (i.e. specifying .synctex.gz), forward search (Shift+F8) doesn't work.

However, Shift+F8 works fine with --synctex=-1.

Shift+F8 also works fine with either SyncTeX switch in WinEdt 7.

Is this a known problem with WinEdt 10, or is there a problem (what?) with my installation?

  • Does this help? tex.stackexchange.com/questions/125546/… – Henri Menke Nov 9 '16 at 14:12
  • @HenriMenke: That question's about inverse search, not forward search. I have no problem with inverse search, whichever SyncTeX switch I use. – David Bevan Nov 9 '16 at 14:19
  • 1
    In WinEdt, go to Options -> Execution Modes -> PDF viewer and set "SyncTeX Switch" to --synctex=1 and "SyncTeX Filetype" to .synctex.gz. Then compile again and retry. It should work (it works fine for me, if it doesn't for you, you must have changed something else in WinEdt configuration) – karlkoeller Nov 9 '16 at 18:20
  • @karlkoeller: Thanks. The SyncTeX Filetype was .synctex, not .synctex.gz. It's a shame it doesn't change automatically when you change the SyncTeX Switch. – David Bevan Nov 10 '16 at 8:09
  • @karlkoeller: Do you want to copy your comment into an answer? – David Bevan Nov 10 '16 at 8:32
4

When, in Options -> Execution Modes -> PDF Viewer, you change the field "Synctex Switch" to --synctex=1, you also have to change the field "SyncTeX Filetype" to .synctex.gz otherwise WinEdt will consider the .synctex file instead of the right .synctex.gz for forward search.

enter image description here

After doing that, simply recompile your file and forward search (Shift+F8 in WinEdt) will work fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.