1

I'm rather new to LaTex and have a problem with the Texmaker editor.

I have a document I've written but when I want to build it (or Quickbuild it), I get this error message. Does anyone have a similar problem and know how to resolve it? I've updated to MacOS sierra and downloaded the latest MacTex distribution from 2016. I've made all the changes from usr to Library in the command tabs but I'm still confused...

Error:

could not start the command : "/Library/TeX/texbin" -synctex=1 -interaction=nonstopmode

Help will be greatly appreciated! :D

Thanks every one!

  • [OFF-TOPIC] If you become an intensive user of LaTex, I recommend you Texpad, in my opinion the best MacOS LaTex editor. Though it's paid, it has a free-trial option. – Héctor Dec 11 '16 at 16:01
2

You have a problem in your preferences. Specifically the one for latex (and/or pdflatex). Please see the `Updating For El Capitan and Sierra' linked at <http://www.tug.org/mactex/sierra.html>. It is also worthwhile reading the other information on that page.

1

Try manually searching within your file system for what TeXMaker is looking for by clicking on the browse button.

If you have cut and pasted someone else's path you found in a post then it may not work. Within TexMaker preferences you should see an option to browse next to the box listing the path. For pdflatex, for example, the path is Library, Tex, then texbin in your post. But when I use the browse setting and select it using TeXMaker's browse option this is not what results. So cutting and pasting others' paths doesn't always work. This was my path once I selected pdflatex through browse, for example:

"/usr/local/texlive/2016/bin/x86_64-darwin/pdflatex" -interaction=nonstopmode %.tex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.