7

I am using the conference IEEEtran document class, and when I type the abstract, instead of being centered, it is on the left column. The instructions say to use the command \IEEEtitleabstractindextext and to use it like a section, but when I do so, the abstract simply disappears.

What do I do?

Would you give me an example on how to use the command?

1
  • Welcome! Please provide the code for a small document we can compile to reproduce the problem. – cfr Nov 13 '16 at 2:14
6

The IEEEtran documentclass follows the IEEE style definitions very, very, very closely... Luckily, everything is well documented in the IEEEtran-HOWTO.pdf document, which is supplied together with the style definitions and a couple of example documents. Please read this document! It contains rules on how to create IEEE-conform papers and many helpful hints.

As described in section V (abstract and index terms),

The IEEE Computer Society and IEEE Transactions on Magnetics formats present a difficulty in that compsoc and transmag journal (but not compsoc conference) papers place the abstract and index terms sections in *single column format just below the author names, but the other IEEE formats place them in the first column of the main text before the first section.

That is why the \IEEEtitleabstractindextext command is only enabled in compsoc and transmag mode, but not in compsoc+conference mode.

The documentation is also very specific in how the command is used: The following code has to be placed before the \maketitle command. Further, they propose to use the command \IEEEdisplaynontitleabstractindextext directly after \maketitle - this combination always typesets the abstract as required by the current settings: in one-column mode for compsoc and transmag, and in two-column mode for most others.

% abstract and (if needed) index terms
\IEEEtitleabstractindextext{%
    \begin{abstract}
        We propose \lipsum[1]
    \end{abstract}
}

% make the title area
\maketitle
\IEEEdisplaynontitleabstractindextext

At the bottom of this answer, I included an example document to show the effect of the documentclass settings on the output, when you use the commands as recommended above.

The first image shows the output for compsoc mode, and not conference mode: the abstract is set in one-column mode. The second image shows the output for both conference and compsoc mode enabled: the abstract is in two-column mode.

compsoc and NOT conference

compsoc and conference

\documentclass[conference,compsoc]{IEEEtran}
\usepackage{lipsum}

\begin{document}
\title{Demo of single-column abstracts}
\author{Homer J. Simpson}

\IEEEtitleabstractindextext{%
\begin{abstract}
We propose \lipsum[1]
\end{abstract}
\begin{IEEEkeywords}
Broad band networks, quality of service, WDM.
\end{IEEEkeywords}}

% make the title area
\maketitle
\IEEEdisplaynontitleabstractindextext

\section{Introduction}
\lipsum[2-7]

% that's all folks
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.