2

Env: Win 7 64 bit (regularly updated)

I had a 32 bit Miktex installation since 2012 that i updated, without a single problem, tenth of times since then, so that i developed the BAD habit of updating without checking first the site.

This morning i run again the update and it badly crashed telling me that it couldn't proceed because C:\Program Files\MiKTeX 2.9\miktex\config\scripts.ini was tampered (for sure not by me!), leaving me with a completely broken installation. compilations no longer running, mpm and update wizard no longer starting.

After reading in the site what was going on, i didn't bother to debug further, i scratched everything and reinstalled the 64 bit (basic-miktex-2.9.6069-x64.exe) after which i run the update and followed step by step the procedure in November package refactoring (i uninstalled and restarted everything from scratch four times just to be sure).

All i obtain is an installation where the update wizard is no longer working and i cannot complete the update process.

Nothing is written in the log, all i see is a pop up that says

Sorry but something went wrong: SSL connect error

but really no real connection problems exists with the repo. I tried four different repos, before update they work, after update they no longer work with update, while mpm still connects without problems.

What i noticed is that the above procedure says that

Package miktex-luatex-base will be replaced by packages luatex, miktex-luatex and tex-ini-files

but package luatex does not exists anywhere. Could be that the cause of the problem? Or the refactoring is somewhere in the middle and not complete and not yet usable for update?

Any idea, anybody?

Thanks, Gabriele

Repository broken

This morning i found again the downloads posted in the Miktex site. I downloaded setup-2.9.6050-x64.exe and installed with it so that packages are downloaded directly from the repo. And here's the result of invoking the update wizard with an out of the box installation:

2016-11-15 07:49:39,471+0100 INFO  Update - starting: Update Wizard (MiKTeX 2.9.6100 64-bit)
2016-11-15 07:49:48,309+0100 INFO  FileCopyPage - 
2016-11-15 07:49:48,309+0100 INFO  FileCopyPage - Error: SSL connect error

Now i can only assume that either there is something changed about repo connections, and i was not able to find doc about, or the refactoring broke the repo.

I changed the title accordingly. If i can give an advice, stay away from update till the whole thing is cleared. I'll try to open a bug.

Gabriele

  • I wouldn't use the basic version for the installation currently. It is quite possible that it is not up-to-date and this is difficult during a refactoring period. Beside this: I have some problems with a miktex installation using the NEXT repositories, but the normal update worked fine (as it is rather old it is still the 32bit version). – Ulrike Fischer Nov 14 '16 at 15:10
  • I was going to follow your advice, but something looks to be going on in the Miktex site. all the downloads, but the 32 bits portable, disappeared. I think i'm going to wait till things settle down a bit. – Gabriele Nov 14 '16 at 15:38
  • 1
    Good idea, it really looks as if something going on. – Ulrike Fischer Nov 14 '16 at 15:46
  • Yeap, it is problematic today (Nov.15, 2016). It cannot establish connection to download. – Pantelis Kazakis Nov 15 '16 at 19:15
2

The problem was solved. Just in case someone happens, like me, to have an IE installation where the Let’s Encrypt root CA certificate is missing, here's what to do. You have two options:

  1. download the certificate from Identrust Download Page saving it in a text file and importing it into the "Trusted Root Certification Authorities" certificate store of your IE 11. Be sure to close all the ie windows before trying the update wizard and you should be running again.

  2. if you have also a firefox installation, chances are that even if it's older than IE it will have the full certificate suite as detailed at the Let's Encrypt certificates page. It's called Digital Signature Trust Co. and from it you can choose to export the DST Root CA X3 certificate. You can export it either in .txt or .crt format and import it into IE as above. If you export it in .crt format, double clicking it will invoke the ie certificate import utility directly.

If after installing the certificate you're still having problems, it's possible that your update, even if you don't get any error message, has gone awry and you have no other chances than uninstall and reinstall at least in my experience. Look towards the end of the cited bug for more tips.

Hope this can help someone to avoid the hassle of the certificate change of the "November update".

Gabriele

0

Looks like the version of the update wizard in the repo has some problems.

Opened bug #2548

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.