5

I moved from one workstation to another (both are Win7) and made exactly the same installation from the same source files: MikTeX 2.9.4813 + TeXstudio 2.6.4.

When compiling the same input *.tex files on the new workstation, I am getting the following messages in the log file:

"pdfTeX warning: pdflatex.exe (file C:/Windows/Fonts/verdana.ttf): glyph `a' not found"

and so on for all the letters.

The resulting pdf shows empty square symbols instead of all letters.

I tried newer versions of MikTeX (2.9.6069) as well as TeXstudio (2.11.2), no change.

I am using:

\usepackage[nofligs]{verdana}

\usepackage[T1]{fontenc}

If I comment out the first line, the result is fine, but not with the verdana font I would like.

How could I solve the problem?


@Ulrike Fischer: sorry for my late response.

1.I do not have the tex256.enc in my new latex installation.

2.If I put one in the same place as it was found on the old installation and do as you proposed, I get the default font in the resulting pdf, not verdana.

3.If I comment out the \fontfamily{verdana}\selectfont, I still get only squares.

4.Am I the first one to use verdana font on the "newer versions of the fonts in windows"? I would say no.


I found a working solution, thanks to Bernard's proposal: comment out the lines:

%\usepackage[nofligs]{verdana}
%\usepackage[T1]{fontenc}

add the lines:

\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{Verdana}

and compile with XeLaTeX.

  • Welcome to TeX SX! Did you think of running updmap.exe --verbose from the command line (as admin)? – Bernard Nov 15 '16 at 11:35
  • The glyph names seems to have changed in newer versions of the fonts in windows. You need either the older fonts or one would have to write new .enc-files which uses e.g. /uni0041 instead of /A and adapt the map-files. No difficult but a lot of work. – Ulrike Fischer Nov 15 '16 at 11:41
  • @Bernard: I have run the command you propose. After lot of "Parsing", "Writing" and "Copying" the command reports, there is no change with the output pdf. – Baltazar Nov 15 '16 at 11:58
  • @Ulrike Fischer: 1) How can use the older fonts? I have already tried overwriting the C:/Windows/Fonts/verdanaX.ttf files with the ones form the older workstation. It didn't help. 2) Where can I find a more detailed explanation about how to write new .enc files and adapt the map files? – Baltazar Nov 15 '16 at 11:59
  • It would be simpler to compile with xelatex. – Bernard Nov 15 '16 at 12:06
4

Here a rough draft what you can try to repair the problem:

  1. Find tex256.enc
  2. rename it as e.g. winfonts256.enc
  3. Replace in this file /T1Encoding [ with /winfontsT1Encoding [
  4. Replace the glyph names by uniXXXX where XXXX is the unicode number of the glyph, e.g. /A by /uni0041 and /a by /uni0061 (there are 256 glyph, so it is some work involved.

After some replacements you can test it like this:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\pdfmapline{= rjvnr8t Verdana " winfontsT1Encoding ReEncodeFont " <[winfonts256.enc <verdana.ttf}
\begin{document}

\fontfamily{verdana}\selectfont
AaTiäöpnß

\end{document}

I made two replacements and so get now this output:

enter image description here

You probably will have to do something similar for ts1-winfonts.enc. All the map entries that you will have to adapt can be found in pdftex.map.

-1

This is working for me:

\documentclass{article}
\usepackage{fontspec}%déjà chargé par luatextra
%\defaultfontfeatures{Ligatures=TeX} % to have the automatics ligatures of TeX
\setromanfont{Verdana}

\begin{document}
\section{Example}
 This is a text in verdana

Math part is not in verdana
$x-3+2=8 $

\end{document}

Resulting in this:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.