0

I am unable to get the eulervm package working properly in this LaTeX beamer presentation (metropolis theme).

Normal math text gets the Fira Sans font and special symbols (e.g. the Omega in \ohm from SIUnits is not displayed, while $\Omega$ is.

MWE:

% !TEX TS-program = xelatex
% !TEX encoding = UTF-8 Unicode
\documentclass{beamer}

\usetheme{metropolis}                     % Use metropolis theme

\usepackage[UKenglish]{babel}
\usepackage{amsmath}
\usepackage[euler-digits,euler-hat-accent]{eulervm} % after amsmath!
\usepackage{tikz} 
\usepackage{circuitikz}
\usepackage[Gray,squaren,thinqspace,thinspace]{SIunits} % elegant units

\begin{document}

\begin{frame}{Alternative Approach: Ramp Generator}
  \centering
  \begin{circuitikz}
    \draw (0,0) to[R,l=\unit{10}{\kilo\ohm}] ++(2,0);
  \end{circuitikz}

  Euler? $\forall x \in \mathcal{R}$. No!

\end{frame}

\end{document}
0

Fixed it by changing the SIunits package to siunitx (and \unit by \SI):

\usepackage{siunitx} % elegant units
\sisetup{
    detect-mode,
    group-digits            = false,
    input-symbols           = ( ) [ ] - +,
    table-align-text-post   = false,
    input-signs             = ,
    %%decimalsymbol=comma, %% not needed, as implied by `locale=DE` option
    locale = UK,
    } 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.