I used the following example from another question:

(XeLaTeX, Texlipse, polyglossia german language issue)

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode


    Test Test Test Test \TeX\ \XeTeX
    \caption{Eine Abbildung}

XeLaTex produces the following error code:

Package polyglossia Warning: \setlocalhyphenmin useless for unknown language     ge
rman on input line 6.

Package polyglossia Warning: No hyphenation patterns were loaded for `ngerman'
(polyglossia)                I will use \language=\l@nohyphenation instead on i
nput line 68.

! Undefined control sequence.
<argument> \xpg@nopatterns {ngerman}\adddialect 
                                                \l@ngerman \l@nohyphenation 
l.68 ...man}{spelling,latesthyphen,script,variant}

Earlier it worked but I can't remember when.

I use MikTeX on Windows 10 x64. I just reinstalled MikTeX again because I suspected the error in a faulty installation of TeX.

Any ideas?

The log-file contains the following file list:

*File List*
scrartcl.cls    2016/06/14 v3.21 KOMA-Script document class (article)
scrkbase.sty    2016/06/14 v3.21 KOMA-Script package (KOMA-Script-dependent bas
ics and keyval usage)
 scrbase.sty    2016/06/14 v3.21 KOMA-Script package (KOMA-Script-independent b
asics and keyval usage)
keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2016/06/14 v3.21 KOMA-Script package (loading files)
tocbasic.sty    2016/06/14 v3.21 KOMA-Script package (handling toc-files)
scrsize11pt.clo    2016/06/14 v3.21 KOMA-Script font size class option (11pt)
typearea.sty    2016/06/14 v3.21 KOMA-Script package (type area)
xltxtra.sty    2016/01/21 v0.6 Improvements for the "XeLaTeX" format
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
fontspec.sty    2016/02/01 v2.5a Font selection for XeLaTeX and LuaLaTeX
expl3.sty    2016/10/19 v6730 L3 programming layer (loader) 
expl3-code.tex    2016/10/19 v6730 L3 programming layer 
xparse.sty    2016/10/19 v6730 L3 Experimental document command parser
fontspec-xetex.sty    2016/02/01 v2.5a Font selection for XeLaTeX and LuaLaTeX
eu1enc.def    2010/05/27 v0.1h Experimental Unicode font encodings
eu1lmr.fd    2009/10/30 v1.6 Font defs for Latin Modern
xunicode.sty    2011/09/09 v0.981 provides access to latin accents and many oth
er characters in Unicode lower plane
eu1lmss.fd    2009/10/30 v1.6 Font defs for Latin Modern
graphicx.sty    2014/10/28 v1.0g Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2016/07/10 v1.0t Standard LaTeX Graphics (DPC,SPQR)
trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
xetex.def    2016/07/11 v4.10 LaTeX color/graphics driver for XeTeX (L3/RRM/
realscripts.sty    2016/02/13 v0.3d Access OpenType subscripts and superscripts

metalogo.sty    2010/05/29 v0.12 Extended TeX logo macros
polyglossia.sty    2015/03/25 v1.42.4 Alternative to Babel for XeLaTeX and LuaL
etoolbox.sty    2015/08/02 v2.2a e-TeX tools for LaTeX (JAW)
makecmds.sty    2009/09/03 v1.0a extra command making commands
xkeyval.sty    2014/12/03 v2.7a package option processing (HA)
xkeyval.tex    2014/12/03 v2.7a key=value parser (HA)
gloss-german.ldf    polyglossia: module for german
babelsh.def    2013/04/30 Babel common definitions for shorthands
Taken verbatim from babel.def (2013/04/15 v3.9e)
t3cmr.fd    2001/12/31 TIPA font definitions

If I compile XeLaTex with command -q to suppress the warnings, I get a PDF-file that looks nearly as intended. Unfortunately, it contains additional characters at the beginning of the document.

After compiling different documents the results are the same. The output is perfect with exception of the additional characters. It's always this one: ÿ

These characters are only on the first page of a document with several pages.

  • Works fine for me, show the complete log-file. – Ulrike Fischer Nov 16 '16 at 21:46
  • How can I upload the log-file? The size is too big for a code block < 30k characters. – RoSt Nov 18 '16 at 2:15
  • It may be enough to just add \listfiles to the start of the document and post the file list part at the end of the log file, which will show the version information. – Nicola Talbot Nov 18 '16 at 14:54
  • You probably don't need xltxtra. However, your code works OK here and I get the same \listfiles output. Try deleting all generated files and recompiling. If you still get an error, you can post the .log file to a paste bin site and give us the link. My log is < 30k characters, though. – cfr Nov 26 '16 at 23:11
  • After recompiling and disabling xltxtra I get the same error. – RoSt Nov 29 '16 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.