0

After having switched computer I had to reinstall TeXLive and TeXMaker on my Mac OS X Yosemite, however, after having done this I whenever I try to compile with (pdflatex) TeXMaker I get the error:

log file not found.

I am aware that this means that TeXMaker is not able to find my TeX distribution, but what baffles me is that if I compile manually via the terminal with

pdflatex test

everything works like a charm.

I have tried to reset the settings (even though they should be after a clean install), without luck. If I first compile via the terminal and afterwards via TeXMaker, I do not get an error, but it does not compile either. Any suggestions?

EDIT: I tried to remove the installation and install it using macTeX in stead of the general installer for Unix systems. Of some reason this helped, even though it have installed the same version in the same location on my harddrive.

  • Assuming you installed TeX Live via MacTeX... which year's TeX Live did you install? what does which pdflatex return? You may have to change some preferences in TeXmaker. – Herb Schulz Nov 17 '16 at 1:05
  • Well, I went to tug.org/texlive and installed the one for "everything else". So it is the one from this year. which peflatex returns /usr/local/texlive/2016/bin/x86_64-darwin/pdflatex – Nicky Mattsson Nov 17 '16 at 7:16
  • I assume you also set a bunch of shell variables. I suggest you go back to tug.org and get MacTeX. – Herb Schulz Nov 17 '16 at 14:32
  • As written in the edit, installing MacTeX did help, but that still does not explain why copying the command that TeXMaker runs directly into the terminal works, but letting TeXMaker run it does not. Also your assumption is right, I did set all the shell variables, otherwise I could not have compiled myself via the terminal. – Nicky Mattsson Nov 18 '16 at 7:45
  • First, remove any setting of TeX related shell variables you set before. Then, what do which pdflatex and echo $PATH return? You may have to change some of TeXmaker's preferences for execution of commands since those paths may be wrong. Although not directly related, you might want to read the `Updating For El Capitan' document at <http://www.tug.org/mactex/elcapitan.html> for an example of the changes that may be necessary. – Herb Schulz Nov 18 '16 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.