In my tex file I have changed the chapter name from 'Chapter' to 'Day', using:

\renewcommand \chaptername {Day}

But when I generate a table of contents it only shows '1' and not 'Day 1'. How do I get the 'Day' to show up in the contents?

2 Answers 2


I recommend using the tocloft package, although I suspect the titletoc package could also be used quite easily. tocloft provides many hooks for content to be inserted into the table of contents.

Here's an example:


In this case \cftchappresnum inserts its argument in the chap entry, pre (before) the snum (sectioning number).

As mentioned by Juan (thanks!), it's also necessary to increase the size of the space allocated for the "chapter number". In this case we calculate how large Day 999 would be (using the calc package) and use that length.

  • 2
    In the above example you also need something like \setlength{\cftchapnumwidth}{1.4cm} to increase the space available to typeset “Day n”. Sep 23, 2010 at 11:45
  • @Juan: I guess you should be the answering, and not me :) Sep 23, 2010 at 11:50
  • This works for me when I copy your example, but I was using the Memoir class for my file, and when I try it in that I get this error: ! LaTeX Error: \cftchappresnum undefined.
    – whoiscraig
    Sep 23, 2010 at 23:41
  • Why does it change the font size of table of content title? How can I resize it with my custom value.
    – meisyal
    Nov 21, 2016 at 5:11
  • Sorry, problem has been solved. I should use title option along with tocloft package if I want to use my custom title. Anyway, thank you for this solution.
    – meisyal
    Nov 22, 2016 at 16:46

Woo, answering my own question!

I probably should have mentioned it was Memoir class in the first place. Anyway, after some investigating, I worked out that I had to add the line:


Which did it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.