1

I am a bit new to latex, I am using ubuntu 14.04. My document was running very fine, after i think after i added glossaries i face this problem. help will be appreciated. Following is main.tex file

\documentclass[12pt]{article}
\usepackage{lipsum}
\usepackage[a4paper,margin=0.9in,includefoot]{geometry}
\usepackage{setspace}
\usepackage{abstract}
\usepackage{tabularx}
\usepackage{multicol}
%================ package for clickable reference%=========

\usepackage[hidelinks]{hyperref}

%============= Package of Accroyns============

\usepackage[nomain,acronym,xindy]{glossaries}
\usepackage[acronym]{glossaries}
\makeglossaries
\usepackage[xindy]{imakeidx}
\makeindex
\input{glossary}


%===================table packages=============%
\usepackage{booktabs}
\usepackage{multirow}
\usepackage{hhline}
\usepackage{array}
\usepackage{longtable}

%======================Math package========================%
\usepackage{amssymb,amsmath}

%= Package for bullents indents spacing and sping betwen bullets ==
\usepackage{enumitem}

\usepackage{amssymb}% http://ctan.org/pkg/amssymb
\usepackage{pifont}% http://ctan.org/pkg/pifont
\newcommand{\cmark}{\ding{51}}%
\newcommand{\xmark}{\ding{55}}%

%================= BIBLIOGRAPHY AND REFRENCES PACKGES %
\usepackage[]{natbib}

%==============Header and footer stuff============%
\usepackage{fancyhdr}
\pagestyle{fancy}

\fancyfoot{}
\fancyhead[RO,LE]{\thepage}
\fancyhead[LO]{\slshape\nouppercase{\leftmark}}
\fancyfoot[re]{\slshape\nouppercase{\rightmark}}

%============Sub and SUperscript package==================
\usepackage{fixltx2e}

%==================== GRAPHICS PREAMBLE %====================
\usepackage{graphicx}
\usepackage{float}
\graphicspath{ {images/} }


%==========Todonotes package============
\usepackage[disable]{todonotes}
\newcommand{\ToDoMG}[1]{\todo[inline,size=\small]{MG: #1}}
\usepackage{longtable}

% Hyphenation
\hyphenation{phe-ro-mo-ne}
\newcommand{\comp}[1]{\texttt{#1}}
\renewcommand*{\glossaryname}{Acronyms}

%***************************************************
% Document
%---------------------------------------------------

\begin{document}

\end{document}
  • Welcome! Please edit your code to provide us with a minimal example which demonstrates the problem you are experiencing. This should contain a probably reduced preamble - only what's necessary - and just enough content to allow us to reproduce the issue. – cfr Nov 17 '16 at 22:41
  • If you compile on the command line, you can see what is printed to the console at the point when the freeze occurs. – cfr Nov 17 '16 at 22:42
  • @cfr console shows log file, it does not show anything specific. – Linux-Fan85 Nov 17 '16 at 22:53
  • Yes, but if you watch it, you can see what it is doing when it freezes e.g. running xindy. If you just look in the log, you can't tell that. – cfr Nov 17 '16 at 23:04
  • @cfr When i start my texmaker and run compile the main.tex and it shows my pdf and the current page that appears is from the second chapter. I mean it should start with the title page. It jumps to the 2nd chapter directly, is it normal too. Please help – Linux-Fan85 Nov 18 '16 at 18:25
1

You use

\usepackage[xindy]{imakeidx}

This means that LaTeX will be running xindy for sorting the glossaries while latexing. This is the delay you notice.

  • I do not know what is causing this delay, I disabled this package and tried but the problem is still there. – Linux-Fan85 Nov 17 '16 at 22:47
  • 1
    You have \input{glossary} in your document. We don't have that file, so we cannot test your document. It is not a MWE. It is also important to know how you run latex on your file. Do you run it from the command line? Or do you use some automatic system that runs makeindex or xindy automatically? – Pieter van Oostrum Nov 17 '16 at 22:51
  • I am using texmaker in ubutnu 14.04. I also tried on command line with the make file too and then run again on texmaker but problem is there. For generating glossaries i ran the commands on command line; pdflatex main , makeglossaries main. – Linux-Fan85 Nov 17 '16 at 22:55
  • Following is the content of my glossary %A \newacronym{aloha}{ALOHA}{Additive Link On-Line Hawaii System} %C \newacronym{capex}{CAPEX}{Capital Expenditure} \newacronym{cdma}{CDMA}{Code Division Multiple Access} \newacronym{csma}{CSMA}{Carrier Sense Multiple Access} %F \newacronym{fdma}{FDMA}{Frequency Division Multiple Access} %I \newacronym{isa}{ISA}{International Society of Automation } %O \newacronym{opex}{OPEX}{operational expenditure} %Q \newacronym{qos}{QoS}{Quality of Service} – Linux-Fan85 Nov 18 '16 at 18:37
  • 1
    So then what command do you use in TeXmaker and how is it configured? I guess it also runs the makeglossaries command, could that be it? – Pieter van Oostrum Nov 18 '16 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.