I have a problem with the \today statement in Latex. As you can see below I'm getting the wrong result for the German date format which would be 17. November 2016.

The gloss-german.ldf defines it in the right order:

  \space \ifcase\month%
  \or\if@austrian@locale Jänner\else Januar\fi\or Februar\or März\or%
  April\or Mai\or Juni\or Juli\or August\or September\or Oktober\or%
  November\or Dezember\fi
  \space \number\year}%

You may try his with the following code:

%!TeX program = xelatex
        German (\textgerman{Deutsch \today}) 

Here my output:

enter image description here

Thanks for your help and sorry for my English.

closed as off-topic by egreg, user13907, Przemysław Scherwentke, Torbjørn T., Heiko Oberdiek Dec 24 '16 at 14:03

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! I get the correct date with XeLaTeX and an error with LuaLaTeX (undefined \luatexpardir, package luatex85 does not help). – Heiko Oberdiek Nov 17 '16 at 22:59
  • I tried this with two different computers and it did't work. Strange. I tried now with TeXworks and recieved the correct date but in Texstudio it doesn't work. Any idea why? – Mathnix Nov 17 '16 at 23:01
  • @HeikoOberdiek luatex commands are enabled unprefixed so it'll be \pardir something needs updating... – David Carlisle Nov 17 '16 at 23:05
  • This might due to bidi. Can you tell what version of it you have? – egreg Nov 17 '16 at 23:07
  • 4
    I'm voting to close this question as off-topic because the issue was solved by a software update – egreg Dec 24 '16 at 12:29

Browse other questions tagged or ask your own question.