0

I am using Miktex2.9 on Windows 10. It was five days ago. Today I am suddenly having a problem.

I use "latex" command from the menu, it is fine. but "DVI->PDF" is not working. and there is an error.

  Process started

  paper.dvi -> paper.pdf [1 xdvipdfmx:fatal: Could not find encoding file "8r". Output file removed.

 Process exited with error(s)

I have checked the internet, but did not see anyone having this error. I remember previously I have a problem with "xdvipdfmx", but I fixed it and it has been working fine.

So, any advice how to fix that ?

Thanks in advance

4
  • it probably doesn't matter but xdvipdfmx is normally only used with xetex and with latex you normally use dvipdfmx Nov 18 '16 at 8:51
  • Did you run an update? Then you perhaps have problems with the november refactoring: miktex.org/alert/package-refactoring-2016-11 Nov 18 '16 at 11:17
  • @UlrikeFischer. I run update, then running "latex" shows an error "! Package graphics Error: No driver specified." . what to do now?
    – alim
    Nov 18 '16 at 16:05
  • @UlrikeFischer. You are right. followed your idea, do something after that, then it worked. Thanks :)
    – alim
    Nov 18 '16 at 16:23
0

Seems what Ulrike Fischer said is right. I updated MiKTeX then run "latex" had some problem. Then I go to MiKTeX setting and choose "ask me first" for "install packages on the fly" option.

Then I run latex again. It asked to install 3-4 packages, then it worked.
Seems November refactoring caused the original problem. Updating somehow deleted some packages, then after installing then Miktex worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.