1

I am using this code:

\documentclass[12pt,peerreview,draftcls,onecolumn]{IEEEtran} %
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{natbib}
\usepackage{graphicx}
\usepackage[tight,footnotesize]{subfigure}
\usepackage{algorithmic}
\usepackage{algorithm}

\begin{document}
...
... policies \cite{1Engelman02FCC} ...
...
\begin{thebibliography}{10}
    \bibitem{1Engelman02FCC} Engelman, R. (2011) `A survey of common control channel design in cognitive radio networks', {\it Elsevier Physical Communication}, Vol. 4, pp. 26-–39.
...
\end{thebibliography}
\end{document}

and this is the result:

enter image description here

It displays references inside the parentheses but I want to display them inside the braces [ ].

  • Off-topic: The subfigure package is considered deprecated. Use the subfig package instead. – Mico Nov 20 '16 at 7:27
  • 1
    try \usepackage[numbers]{natbib} – Elad Den Nov 20 '16 at 7:29
  • @EladDen - Your suggestion has three issues: (a) parentheses will still be used, instead of brackets; (b) The font size used in the bibliography won't be correct for the IEEEtran document class; and (c) one will get specious warnings because natbib is looking for a \bibliographystyle instruction. These warnings can, admittedly, be ignored in the present case; nevertheless, it's probably a good idea to point this out explicitly. – Mico Nov 20 '16 at 7:36
1

It looks like you're building the bibliography "by hand", i.e., without the help of a utility such as BibTeX. If that's the case, you needn't load the natbib citation management package. By not loading this package, square brackets instead of round parentheses will be used to enclose the citation call-out markers.

If, for some reason, you believe you must load the natbib package, you should (a) set the options square and numbers and (b) also issue an instruction such as \bibliographystyle{plain} in the preamble. If you pursue this route, though, you'll find that LaTeX isn't using the correct (\footnotesize) font size for bibliographic entries. (The IEEEtran document class uses \footnotesize for the bibliography.)

Instead of loading natbib, you might consider loading the cite citation management package: doing so won't change the font size used in the bibliography. Or, as already suggested above, don't load a citation management package at all.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.