2

I am trying to the cite the following thing correctly. I have these instructions.

How to cite: National Library of Medicine, or "Vancouver style" (International Committee of Medical Journal Editors):

DynaMed Plus [Internet]. Ipswich (MA): EBSCO Information Services. 1995--. Record No. 909124, Electrocardiogram (ECG); [updated 2016 Apr 20, cited place cited date here]; [about 30 screens]. Available from http://www.dynamed.com/login.aspx?direct=true&site=DynaMed&id=909124. Registration and login required.

.tex

\documentclass{article}
\usepackage[numbers]{natbib}

\begin{document}
\cite{dynmedECG}
\bibliographystyle{vancouver}   % Mico; https://www.imperial.ac.uk/media/imperial-college/administration-and-support-services/library/public/LaTeX-example-Vancouver-branded-jan-2016.pdf  
\bibliography{thesis}
\end{document}

My wrong proposal in file.bib

@article{dynmedECG,
   author = "DynaMed Plus [Internet]", 
   journal = "Ipswich (MA): EBSCO Information Services", 
   year  = "1995 - ", 
   title = "Record No. 909124, Electrocardiogram (ECG)", 
   note = "[updated 2016 Apr 20, cited place Riga cited date Nov 20 2016]; [about 30 screens]. Available from http://www.dynamed.com/login.aspx?direct=true&site=DynaMed&id=909124. Registration and login required."
}

Output after many iterations

Package natbib Warning: Citation `dynmedECG' on page 10 undefined on input line
 589.

Testing to apply Mico's proposal.

Here are my complete packages which may cause the complication. Here my .bib file.

Fig. 1 Output in my current setting

enter image description here

Output: question marks in the body when citing to the source

Output

! Misplaced alignment tab character &. l.14 ...://www.dynamed.com/login.aspx?direct=true& site=DynaMed&id=909124. ? ! Misplaced alignment tab character &. l.14 ...d.com/login.aspx?direct=true&site=DynaMed& id=909124.

My proposal for the solution in .bib. with {\&} but I still cannot get it work; I also tried with \&

% Mico
@misc{dynmedECG,
   author = "{DynaMed Plus [Internet]. Ipswich (MA): EBSCO Information Services}", 
   year  = "1995--", 
   note = "{Record No. 909124, Electrocardiogram (ECG)}", 
   howpublished = "{[updated 2016 Apr 20, cited place: Riga; cited date: Nov 20 2016]; [about 30 screens]. 
        Available from \url{http://www.dynamed.com/login.aspx?direct=true{\&}site=DynaMed{\&}id=909124}. 
        Registration and login required.}"
}

TeXLive: 2016
OS: Debian 8.5

  • 3
    Since the instruction is to use "Vancouver" style, why are you using the unsrtnat bibliography style instead of the vancouver bibliography style? Also, why are you using the @article entry type for a piece which clearly wasn't published in an academic journal? – Mico Nov 20 '16 at 18:56
  • @Mico Thank you! I thought unsrtnat is Vancouver. I changed the body. Still, I get no entry with the bib entry. – Léo Léopold Hertz 준영 Nov 20 '16 at 18:58
  • 1
    The vancouver style places the year field soon after the author field (and, if present, the title field). That's what appears to be required here. In contrast, the unsrtnat style places the year field pretty much at the very end of the formatted entry. – Mico Nov 20 '16 at 19:26
  • Judging by the screenshot you posted, you may not have loaded the natbib package with the option numbers. – Mico Nov 22 '16 at 14:15
3

Some suggestions:

  • Use the vancouver bibliography style. Unlike the unsrtnat bibliography style, vancouver inserts the year field immediately after the author and title fields.

  • Since the entry contains a URL string, be sure to load the url package and to encase the entire URL string in a \url directive.

  • Use the @misc entry type for this entry, as it's not a piece that was published in an (academic) journal.

  • Be sure to encase the entire author field in an extra pair of curly braces, to inform BibTeX that this is a single, "corporate" author.

  • The ordering of the fields recommended by Dynamed -- author, address and publisher, year, and only then title, followed by the URL and some final, ancillary information -- is rather uncommon, and it can't be handled by the vancouver style if you were to use the usual field names title and howpublished unless you were to hack the style file, which I don't recommend you do. To handle this rather uncommon ordering of the fields, I suggest that you

    • place the address and publisher information at the end of the author field;

    • place the contents of the title field into the note field, and thus not have a title field at all -- this is actually permissible with the @misc entry type; and thus

    • use both note and howpublished and fields.

Observe that you should (actually, must!) encase the URL string in a \url directive.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{thesis.bib}
@misc{dynmedECG,
   %% Some unusual aspects of this entry:
   %% - 'author' field also contains address and publisher information
   %% - 'note' field contains what appears to be the title of the publication
   %% - 'howpublished' field contains all remaining information
   author = "{DynaMed Plus [Internet]. Ipswich (MA): EBSCO Information Services}", 
   year  = "1995--", 
   note = "{Record No. 909124, Electrocardiogram (ECG)}", 
   howpublished = "[updated 2016 Apr 20, cited place: Riga; cited
        date: Nov 20 2016]; [about 30 screens]. Available from
        \url{http://www.dynamed.com/login.aspx?direct=true&site=DynaMed&id=909124}. 
        Registration and login required."
}

\end{filecontents}

\documentclass{article}
\usepackage[numbers]{natbib}     % create numeric-style citatin call-outs
\usepackage[hyphens,spaces]{url} % allow line breaks at hyphens and spaces

\begin{document}
\cite{dynmedECG}
\bibliographystyle{vancouver}  
\bibliography{thesis}
\end{document}
  • Yes, I am loading url, see here complete paste.ubuntu.com/23508124 I enclose URL string with \url{...}. I just copy-pasted your proposal to by .bib file. – Léo Léopold Hertz 준영 Nov 20 '16 at 19:36
  • Fixed but does not help. The condition persists. Is there anything critical mistakes in my .bib file which may cause the conflict paste.ubuntu.com/23508342 ? The new entry is at the end. Please, see the body for my output. – Léo Léopold Hertz 준영 Nov 20 '16 at 20:12
  • @Masi - Clearly, as the screenshot above shows, my answer works properly. If your software doesn't allow you to copy and paste my code correctly, then it's a matter of your software, which you need to fix. I don't think there's anything more for me to do here. Period. – Mico Nov 20 '16 at 20:29
  • It is not editor problem. I reproduced it now in Vim and Emacs. The problem is caused by the symbols & in howpublished? How can you overcome it? – Léo Léopold Hertz 준영 Nov 20 '16 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.