3

my previous question has not been solved. I had problem with TexMaker which told me "File not Found" when I open Thesis.tex. The question link is https://tex.stackexchange.com/questions/339701/file-not-found-which-i-have-ready-activated-pdflatex

I have opened my tex files with notepad and copied the script and created new tex files. Now when I compile the data, it come out the following errors:

This is BibTeX, Version 0.99d (MiKTeX 2.9) The top-level auxiliary file: Thesis.aux 
I found no \citation commands---while reading file Thesis.aux 
I found no \bibdata command---while reading file Thesis.aux 
I found no \bibstyle command---while reading file Thesis.aux 
(There were 3 error messages)

How can I solve this? updated script, very short one, new error: I couldn't open file name `test.aux'

Thank you

\documentclass{article}  
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{microtype}
\usepackage[backend=bibtex,
                style=authoryear,
                natbib=true, 
                style=numeric-comp
                ]{biblatex}    
\usepackage[english]{babel}
\usepackage{filecontents}
\begin{document}  
\begin{filecontents*}{\jobname.bib}
  @book{ASH,
    author = {Seiffert, U. & Wech, L.},
    year = {2003},
    title = {Automotive Safety Handbook},
  }
\end{filecontents*}
Test of bibliography: 
This comes from \cite{ASH}.
\printbibliography
\end{document} 
10
  • 1
    You did not provide a compilable example. Does your document have any cite commands? Why are you using bibtex instead of biber? – Johannes_B Nov 21 '16 at 17:34
  • Have you tried clearing all auxiliary files and start the compile chain again? latex thesis, bibtex thesis, latex thesis, latex thesis – Johannes_B Nov 21 '16 at 17:35
  • I don't know how I can provide a proof that I used "cite" command. as the citation is in chapter but not in the master file. My reference (Bib.bib) has been created by JabRef @Johannes_B – Vivian Nov 21 '16 at 17:38
  • You are able to read german, right? golatex.de/… – Johannes_B Nov 21 '16 at 17:39
  • @Johannes_B my English is better than my German. I can't read very fast and find the solution when I read long text in German. – Vivian Nov 21 '16 at 17:45
4

Too long for a comment, but here is a working version of the code in your question:

Changes:

  • Used and instead of & in the author entry. Authors should always be separated by the keyword and. And & alone will generate an error anyways, as it's an active character used as the column separator in tables and the like, so you need \& to print an ampersand in the text.

  • \Bib.bib -> \jobname.bib.

  • Added \addbibresource{\jobname.bib}. Note that it is added after the filecontents environment, to ensure that the file exists when \addbibresource looks for it.

  • Added a citation to the only entry: \cite{ASH}.

If you get some errors about .aux file or similar, try deleting the .aux and the .bbl file, and then run pdflatex, bibtex and twice pdflatex again.

\documentclass{article}  
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{microtype}
\usepackage[backend=bibtex,
                style=authoryear,
                natbib=true, 
                style=numeric-comp
                ]{biblatex}    
\usepackage[english]{babel}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
  @book{ASH,
    author = {Seiffert, U. and Wech, L.},
    year = {2003},
    title = {Automotive Safety Handbook},
  }
\end{filecontents*}
\addbibresource{\jobname.bib}
\begin{document}  
\cite{ASH}
\printbibliography
\end{document} 
3
  • Thank you! But the error is still there... I don't understand why because the test.aux is not in the folder at all, it's not even generated.In Tools->configuration->bib(la)tex "C:/Program Files (x86)/PortyTeX/portyTeX/MiKTeX_Portable/miktex/bin/bibtex.exe" % Is that sth wrong here? – Vivian Nov 21 '16 at 20:05
  • @Vivian The .aux file should be generated when you run pdflatex, you did that first right? If yes, read on. You're using Texmaker? Have you by any chance selected the option for "Use a build subdirectory for ouput files" in Options -> configure texmaker? If yes, unselect that option and try again. – Torbjørn T. Nov 21 '16 at 20:23
  • First make sure you clean out all the old files before compiling. Basically you were missing the \addbibresource{\jobname.bib} command(which tells bibtex which .bib file to use) and you need to use \& rather than & alone in the bib entry. – Herb Schulz Nov 21 '16 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.