Every once in a while I have an issue with Skim's reverse / inverse search and ST3: the usual shift + command + click (Mac) opens a new doc in a new tab that is empty instead of bringing me to the corresponding line in the original doc.

Searches online turned up nothing and other related questions posted here did not address this specific issue, so here's hoping this will save others with the same issue some effort.

1 Answer 1


In my case the issue was the use of backslashes in the doc title or anywhere in the folder structure of the path. e.g. a folder titled maybe / maybe not broke the inverse-search functionality. Removing them was sufficient to restore the functionality.

If you have just set up Skim, NB you will have to go to preferences > sync and select the appropriate preset for this functionality to work.

  • 2
    Interesting point. It looks like ST converts slashes to : in the file name, hence the mismatch.
    – ig0774
    Commented Nov 28, 2016 at 17:23
  • For anyone in the future: I had the same issue, but it was my use of dashes, like folder-1, that caused the problem. Both in the document title and in the folder path. Removed the dashes everywhere and it works fine now. Commented Apr 6, 2019 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .