6

I am beginning in TexMaker and I want to change into the dark mod (direct request of my eyes).

In the configurations, I clicked on the dark theme button but nothing changed, even by restarting the program. Any indication guys ?

Moreover I tried to change the .init file, but after a restart, the file turned like it was before.

Thanks a lot for your help !

3
  • 3
    After the restart did you try opening a file to edit. That is when the dark theme is used (in the edit window) not the entire texmaker window. Nov 25, 2016 at 1:20
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Nov 25, 2016 at 6:07
  • 1
    Related question if you decide to switch to TeXstudio
    – ebosi
    Nov 25, 2016 at 10:03

4 Answers 4

4

If R. Schumacher's comment didn't help out and your Texmaker is still not in the dark theme, you can just fill in the colours yourself, because (as far as I can tell) the dark theme button just changes the hexadecimal values. I'll list them here for you:

  • Background: #0c1021
  • Current line: #131727
  • Highlighted line: #FF0000
  • Text: #f8f8f8
  • Comment: #aeaeae
  • Math: #61ce3c
  • LaTeX command: #8da6ce
  • Structure: #fadd2d
  • Verbatim: #e6a252
  • Todo: #FF6400
  • Graphic keywords: #f47bda
  • Graphic Numbers: #660066

Hope this helps, because I can't really work with a white background myself for a long time so I know the pain!

0

you need to press "Enter" after you make the changes, they do not have an "Apply" button in the dialogue box.

0

I usually try not to mess with the settings. Instead of this on my Windows computer, I use color filter settings. Select inverted filter and use the "win + ctrl + C" shortcut to invert the colors.

0

Easiest way: go to --> preferences --> editor settings --> select dark mode, press ok!! for reference, see the image

1
  • Welcome to TeX.SE!
    – Mensch
    Mar 11 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .