1

I am writing my thesis and everything is working grat except the quoting from the bibliography. I have to say that I am more or less a newbee in this topic - so far I did with the normal bibliography "thebibliography", but I would like to use BibLaTex instead in order to have a better overview over all citations. Also it would be nice to use the abreviations including the first letters of the author and the latter two numbers of the year, e.g. "Fe02".

What I have so far is the following bib-file (only one element shown) saved under the name mylibrary.bib in the same location as the other tex-files.

@BOOK{fernholz02,
    AUTHOR = {Fernholz, E. Robert},
    YEAR = {2002},
    TITLE = {Stochastic Portfolio Theory},
    EDITION = {1st edition},
    ISBN = {978-1-4419-2987-7},
    PUBLISHER = {Springer Science + Business Media New York},
}

Now I have inserted the library in my tex-file in the following way (neglected the other things in the preamble):

\documentclass[a4paper]{report}
\usepackage[ngerman,english]{babel}
\usepackage[backend=biber]{biblatex}
\usepackage{csquotes}
\bibliography{mylibrary} 


\begin{document}

    \section{introduction}

    This is the introduction and \cite{fernholz02} is such a nice book that it is often-cited in this thesis.
    \printbibliography
\end{document}

When running the compiler with PDFLaTeX, it gives the following error messages. Mainly, he couldn't find the bibliography.

Citation 'fernholz02' on page 1 undefined
Empty bibliography
There were undefined references.
Please (re)run Biber on the file.... and rerun LaTeX afterwards.

I have already searched in other questions for the solution. Suggested was for example to run first PDFLaTeX, then BibTeX and then twice PDFLaTeX again. But this ends by the second time of compiling in an error message related to BibTeX:

This is BibTeX, Version 0.99d (TeX Live 2014/W32TeX) The top-level auxiliary file: test_biblio.aux I found no \citation commands---while reading file test_biblio.aux I found no \bibdata command---while reading file test_biblio.aux I found no \bibstyle command---while reading file test_biblio.aux (There were 3 error messages)

What I am doing wrong? I appreciate any help - thanks already!

marked as duplicate by user114143, moewe biblatex Nov 25 '16 at 14:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to TeX.SX! In general the use of BibTeX ou Biber require a bibliography style which must be given through biblatex as an Option (e.g. style=numeric) The use of \bibliography{<bib file>} is deprecated, use \addbibresource{<bib file>.bib} (note the file extension). For more, check this question: tex.stackexchange.com/questions/13509/… – Guilherme Zanotelli Nov 25 '16 at 13:14
  • Thanks Guilherme! I have added the bibl. style and changed to addbibresource as you suggested. But I still get the error message by running BibTex in the second try after LaTeX, also after readjusting the BibTex command line into bibtex8 --wolfgang % as in the link. The 8-bit codepage and sorting file: 88591lat.csf The top-level auxiliary file: test_biblio.aux I found no \citation commands---while reading file test_biblio.aux I found no \bibdata command---while reading file test_biblio.aux I found no \bibstyle command---while reading file test_biblio.aux (There were 3 error messages) – psc Nov 25 '16 at 13:46
  • Well, that's because you should be using Biber as you specified it in you MWE saying \usepackage[backend=biber]{biblatex}. If you wish to use BibTeX than Change to backend=bibtex. – Guilherme Zanotelli Nov 25 '16 at 13:48
  • As Guilherme already said, you need to run Biber and not BibTeX or BibTeX8, see Biblatex with Biber: Configuring my editor to avoid undefined citations for help on running Biber from your favourite editor. – moewe Nov 25 '16 at 13:59
  • Thanks! It is working now with biber, I forgot to add it in the options as command. The Bibliography gets printed. But how can I change the numbers to letters, e.g. "Fe02"? – psc Nov 25 '16 at 14:45