3

I am trying to install texlive on my Windows 7 32 bit PC. Here is what I've done:

  • Downloaded and extracted install-tl.zip.

  • Added path to Perl and Wget to my environment variable PATH.

  • since I am behind a proxy server, I command set http_proxy=http://username:password@123.45.67.89:9090 set https_proxy=https://username:password@123.45.67.89:9090

  • cd to \install-tl-20161124

  • install-tl-advanced.bat -gui=perltk

It gives the following "Inappropriate I/O control operation" error, and quits installation: C:\Users\<user>\Desktop\install-tl-20161124\install-tl: open tlpdb(http://ctan.imsc. res.in/tlpkg/texlive.tlpdb) failed: Inappropriate I/O control operation at C:/Us ers/AQ/Desktop/install-tl-20161124/tlpkg/TeXLive/TLPDB.pm line 359.

The post here suggests to try a different mirror. I have tried different mirrors by using --repository option for the install-tl-advanced.bat command. But the result is same.

A similar issue has also been reported on the texlive mailing list here a couple of months back. But I could not find any solution there.

Can anyone help?

  • I get a very similar error message on OSX when trying to run tlmgr update --self – gen Feb 11 '18 at 10:42
0

Ok, apparently it should, but it does not work when given the option -gui=____ along with the install-tl-advanced.bat. It is working fine without giving the -gui option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.