4

I am using german quotation marks in my LaTeX document. See for example the following code:

\documentclass[a4paper,12pt,numbers=endperiod]{scrartcl}
\usepackage[left=2.5cm,right=2.5cm,top=2.5cm,bottom=2cm,footskip=1cm]{geometry}
\usepackage{setspace}
\usepackage{yfonts}
\usepackage{lmodern}
\usepackage{CJKutf8}
\usepackage[footnote,printonlyused]{acronym}
\usepackage[utf8]{inputenc}
\usepackage[T2A,T1]{fontenc}
\usepackage[russian,ngerman]{babel}
\usepackage{tipa}
\usepackage{csquotes}
\DeclareRobustCommand{\cyrins}[1]{%
    \begingroup\fontfamily{cmr}%
    \foreignlanguage{russian}{#1}%
    \endgroup
}
\begin{document}
    Comma: blah, \\
    Quotation marks: \glq{}blah\grq{} and \glqq{}blah\grqq \\
    This comma , and this quotation mark \glq{} are equal.
\end{document}

It does everything I need it to do but my quotation marks are identical to the commas in the text which really bothers me.

enter image description here

Is there a way to make the quotation marks (I always enter them like \glqq \glq \grqq and \grq) distinguishable from my commas?

  • That's not quite a complete, but minimal .tex file. You are missing the part that actually gets typeset (and including many packages which have nothing to do with the problem -- off-topic, but do you know why you are loading each of those packages?). – jon Nov 26 '16 at 6:23
  • In all fonts I know, the low quotation marks are commas. Note that a comma is always followed by a space and never preceded by a space; for the low quotation mark it's the converse. – egreg Nov 26 '16 at 9:18
  • @jon sorry for being a little all over the place and not deleting the unnecessary parts. but I am aware why I use each and every package but I am a linguist so I need it to do it all, which seems to have also its downsides... – LajosH Nov 30 '16 at 17:15
  • @egreg thanks for pointing that out, I didn't really realize that. but even though the characters are distinguishable like that, it still just is ugly to me – LajosH Nov 30 '16 at 17:15
3

It depends on your font. For example:

\documentclass{article}

\usepackage{fontspec}

\setmainfont{Abyssinica SIL}

\begin{document}

x, ‚x

\end{document}

(Left is the comma and right is the low quotation mark.)

Produces (magnified):

x, ‚x

There's a noticeable difference between the two punctuation characters.

Whereas:

\documentclass{article}

\usepackage{fontspec}

\setmainfont{Nimbus Roman No9 L}

\begin{document}

x, ‚x

\end{document}

produces

x, ‚x

which is less noticeable.

Now with LaTeX (rather than the above XeLaTeX examples):

\documentclass{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}

x, ‚x

\end{document}

x, ‚x

There's no difference that I can see here. I tried with a few font packages and haven't found any that produced different results, so it could be that U+201A is just mapped to a comma by inputenc or it could be that the fonts use the same shape for both characters.

Edit: If you're restricted to PDFLaTeX, then it's possible to fake a low open quote. It's not as good as using the proper character, but it might be enough for your requirements.

This example just creates a slightly deformed comma by shrinking it vertically:

\documentclass[12pt]{article}

\usepackage{lmodern}
\usepackage[T1]{fontenc}

\usepackage{graphicx}

\newcommand{\lowopenquote}{\scalebox{1}[0.75]{,}}

\begin{document}

x, \lowopenquote x

\end{document}

This produces:

x, ,x

The spacing can be adjusted so that it's closer to the following letter:

\documentclass[12pt]{article}

\usepackage{lmodern}
\usepackage[T1]{fontenc}

\usepackage{graphicx}

\newcommand{\lowopenquote}{\scalebox{1}[0.75]{,}\hskip-.05em}

\begin{document}

x, \lowopenquote x

\end{document}

x, ,x

A rather more elaborate solution is to actually draw the symbol using, for example, tikz:

\documentclass[12pt]{article}

\usepackage{lmodern}
\usepackage[T1]{fontenc}

\usepackage{tikz}

\newcommand{\lowopenquote}{%
 \begin{tikzpicture}[x={.5em},y={.5em},baseline=4.62em]
 \fill (1.563802,9.260839)
 .. controls (1.563802,9.227274) and (1.557653,9.196494)
 ..(1.545356,9.168499)
 .. controls (1.533058,9.140505) and (1.518519,9.115765)
 ..(1.501736,9.094281)
 .. controls (1.484954,9.072796) and (1.468171,9.054567)
 ..(1.451389,9.039593)
 .. controls (1.434606,9.024619) and (1.42173,9.013081)
 ..(1.41276,9.004979)
 -- (1.361762,9.015613)
 .. controls (1.376953,9.030949) and (1.391602,9.046646)
 ..(1.405707,9.062705)
 .. controls (1.419813,9.078764) and (1.432111,9.095546)
 ..(1.4426,9.113052)
 .. controls (1.453089,9.130558) and (1.461372,9.14857)
 ..(1.467448,9.167089)
 .. controls (1.473524,9.185607) and (1.476345,9.204994)
 ..(1.475911,9.225248)
 .. controls (1.475911,9.228721) and (1.475658,9.232808)
 ..(1.475152,9.23751)
 .. controls (1.474646,9.242212) and (1.474392,9.246371)
 ..(1.474392,9.249988)
 -- (1.387804,9.249988)
 .. controls (1.383898,9.254907) and (1.380353,9.260043)
 ..(1.37717,9.265396)
 .. controls (1.374421,9.270315) and (1.372034,9.27603)
 ..(1.370009,9.28254)
 .. controls (1.367983,9.289051) and (1.36697,9.296357)
 ..(1.36697,9.304459)
 .. controls (1.36697,9.328185) and (1.374132,9.348078)
 ..(1.388455,9.364137)
 .. controls (1.402778,9.380196) and (1.423177,9.388226)
 ..(1.449653,9.388226)
 .. controls (1.484086,9.388226) and (1.511719,9.37705)
 ..(1.532552,9.354697)
 .. controls (1.553385,9.332345) and (1.563802,9.301059)
 ..(1.563802,9.260839) --cycle;
 \end{tikzpicture}%
}

\begin{document}

x, \lowopenquote x

\end{document}

x, ,x

This may not respond well to font changes. (It should resize, but can't change to bold, italic etc.)

  • Thank you for your help! Unfortunately I use pdfLaTeX since I didn't want to change to XeLaTeX in the middle of my thesis... – LajosH Nov 30 '16 at 17:17
  • @LajosH I've updated my answer with examples simulating the character for pdfLaTeX. – Nicola Talbot Dec 5 '16 at 10:17
2

There is the possibility to use options autostyle,german=guillemets with package csquotes. In my opinion the guillemets are better, because they clearly differ to a coma, as it seems you want to get ... Please note the new commands \enquote, \enquote* and \guilsinglright I used in the following code. You can find this informations in the package documentation too (try texdoc csquotes on your console/terminal).

MWE:

\documentclass[a4paper,12pt,numbers=endperiod]{scrartcl}
\usepackage[left=2.5cm,right=2.5cm,top=2.5cm,bottom=2cm,footskip=1cm]{geometry}
\usepackage{setspace}
\usepackage{yfonts}
\usepackage{lmodern}
\usepackage{CJKutf8}
\usepackage[footnote,printonlyused]{acronym}
\usepackage[utf8]{inputenc}
\usepackage[T2A,T1]{fontenc}
\usepackage[russian,ngerman]{babel}
\usepackage{tipa}
\usepackage[autostyle,german=guillemets]{csquotes} % <==================
\DeclareRobustCommand{\cyrins}[1]{%
    \begingroup\fontfamily{cmr}%
    \foreignlanguage{russian}{#1}%
    \endgroup
}
\begin{document}
    Comma: blah, \\
    Quotation marks: \glq{}blah\grq{} and \glqq{}blah\grqq \\
    This comma , and this quotation mark \glq{} are equal.

Comma: blah, \\
Quotation marks: \enquote*{blah} and \enquote{blah} \\ % <==============
This comma , and this quotation mark 
\guilsinglright  %text \guilsinglleft 
are not equal.
\end{document}

giving the resulting pdf:

enter image description here

  • Thank you! That is a really smooth solution (that makes quoting even faster for me) but unfortunately I write a linguistic thesis so my choice of characters is quite limited because they already have a codified meaning so I really have to stick to the other quotation marks. Would it be possible to change the font just for the quotation marks so they are still commas but have a different look? – LajosH Nov 30 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.