2

I think that it is a little off-topic and some kind stupid question. I hope you will not unvote me :)

But, I used TexMaker a lot, and now for some reasons I should use TexStudio on my notebook. I've installed it on Windows.

I have a big book. And surprise is that command pdfLatex is maded three times in a row before viewing this big document. TexMaker did not do that in a such way. TexMaker call commands which together are made three-four times faster.

I've checked the settings. Everything is clear for the first look.

PS. For small documents TexStudio has a perfect speed of MikTex-compiling+viewing and pdfLatex is made one time.

I see that TexStudio runs bibtex, but I do not ask him to do it, just pdfLatex. I feel stupid.

Here are logs to a big document. Can it be done by TexStudio as fast as TexMaker? They are just editors! What do they call differently?

Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "Information Security".tex
Process started: bibtex.exe "Information Security"

This is BibTeX, Version 0.99d (MiKTeX 2.9.6100 64-bit)
The top-level auxiliary file: Information Security.aux
I found no \citation commands---while reading file Information Security.aux
I found no \bibdata command---while reading file Information Security.aux
I found no \bibstyle command---while reading file Information Security.aux
(There were 3 error messages)

Process exited with error(s)

Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "Information Security".tex
Process started: bibtex.exe "Information Security"

This is BibTeX, Version 0.99d (MiKTeX 2.9.6100 64-bit)
The top-level auxiliary file: Information Security.aux
I found no \citation commands---while reading file Information Security.aux
I found no \bibdata command---while reading file Information Security.aux
I found no \bibstyle command---while reading file Information Security.aux
(There were 3 error messages)

Process exited with error(s)

Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "Information Security".tex

Process exited normally

Here are my settings for Options -> build. enter image description here And here are for options -> commands enter image description here

With samcarter's hint my several advance setting are next enter image description here

PPS. After finding an answer I really feel stupid. How I did not notice all these things? lol

  • 1
    In your last image, are any of the play buttons green? I think those are the ones that control the multiple compilations in a row feature in TS. – daleif Nov 27 '16 at 10:56
  • 2
    @daleif In the last image (in that page of settings I mean) there is no green colour. But in options->commands->tickadvanced there were a green colour for pdfLatex and some other... Oh my god, it works. It was so easy. If you wish, you can make an answer, I will accept. – Lust_For_Love Nov 27 '16 at 11:09
4

I usually don't use texstudio (and is not at a pc), so is writing this from memory.

First of show the advanced options just if something is hidden there.

TS' feature of running multiple times is usually shown with the play icon being green. So look for a green icon on pdflatex. You can usually hover the mouse over it to learn what it can do.

enter image description here

  • 2
    Actually, that isn't enough. Also on the Commands section of the configuration there are repeat icons, that have to be switched off. And then there is on the Build screen the option "Check and update bibliography before compiling" that should be unchecked. Al these are only visible with "Show Advanced Options". – Piet van Oostrum Nov 27 '16 at 12:12
  • Hmm, samcarter found that this solution has one disadvantage. – Lust_For_Love Nov 27 '16 at 21:07
  • @Dida as mentioned I don't use this editor. At times one just has to accept the limitations in the tools you use. I hardly ever compile from the editor, I use latexmk in continuous preview mode. This means I don't have the error scanning from the editor (because it does not know when the compilation is finished), but I don't really miss it. – daleif Nov 27 '16 at 21:12
2

Sounds like you are a victim of the automatic pre-compile from texstudio.

As demonstrated in daleif's answer, this can be switched of by disabling the "rerunability" of a command. However this has a major disadvantage: The log file is only updated for rerunable commands, see https://sourceforge.net/p/texstudio/bugs/1887/ for explanation.

A workaround: Replace the internal precompile by some quick and harmless command (but it cannot be empty). On linux I simply use echo " ". I don't know what a good alternative would be for windows, though.

enter image description here

  • Hm, I do not have such items in options -> build. Please, look at updated question for my settings. – Lust_For_Love Nov 27 '16 at 0:10
  • @Dida show advanced options at the bottom has to be enabled. – user36296 Nov 27 '16 at 0:22
  • 1
    Is echo a Windows command? @Dida – cfr Nov 27 '16 at 3:18
  • 1
    @cfr I had the same your doubt but maybe yes: technet.microsoft.com/en-us/library/bb490897.aspx – CarLaTeX Nov 27 '16 at 4:32
  • 1
    @Dida In Windows OS, try, for example, the following command: cmd /c "echo." – Vladimir S. Jul 13 '17 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.