1

I was trying to enlarge a bit some equations, and I tried EVERYTHING.

\large \Large \begin{large} \mathlarger..

None of those commands work. I don't know what to try. Does anyone have some idea?

If this help, here is my LaTeX "starting code":

\documentclass[danish, a4paper, 12pt]{report}
%\documentclass{article}
\usepackage[paperheight=28cm, paperwidth=20cm, margin=2cm]{geometry}
\usepackage[T1]{fontenc}
\usepackage[urw-garamond]{mathdesign}
\usepackage[english]{babel}
%\usepackage[italian]{babel}
\usepackage[utf8]{inputenc}
\usepackage[usenames,dvipsnames]{color}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{multicol}
\usepackage{tabularx}
\usepackage{amsopn}
\usepackage{xparse}
\usepackage{physics}
\usepackage{wasysym}
\usepackage{pstricks}
\usepackage{pspicture}
\usepackage{mathrsfs}
\graphicspath{{"Immagini/"}}
\usepackage{mathtools}
\DeclarePairedDelimiter\ceil{\lceil}{\rceil}
\DeclarePairedDelimiter\floor{\lfloor}{\rfloor}
\definecolor{ballblue}{rgb}{0.13, 0.67, 0.8}
\definecolor{apple}{rgb}{0.55, 0.71, 0.0}
\definecolor{awesome}{rgb}{1.0, 0.13, 0.32}
\definecolor{azure}{rgb}{0.0, 0.5, 1.0}
\newcommand\Large{\@setfontsize\Large\@xviipt{22}}
\DeclareMathOperator{\de}{\text{d}}
\newenvironment{sistema}%
{\left\lbrace\begin{array}{@{}l@{}}}%
{\end{array}\right.}
\renewcommand\theequation{\arabic{equation}}

\begin{document}

cui e chiesto un tempo $t^*$ per il quale il peso e il doppio, ossia
$$P(t^*)=2P_0$$
Si agisce come prima, solo che in questo caso l'incognita è il tempo,
e si scrive
$$2P_0 = \scalebox{2}{e^{\frac{\ln(1.4)}{30}\ t^*}}$$

\end{document}

As you can see, I also tried with

\newcommand\Large{\@setfontsize\Large\@xviipt{22}}

and nothing happens...

After having tried with "scale box" and after having failed again... here is a screenshot of the log.

enter image description here

  • 3
    No indeed, these commands apply to text, but not to mathematical equations and objects. Try tex.stackexchange.com/questions/3703/make-equations-large, tex.stackexchange.com/questions/7462/…, tex.stackexchange.com/questions/160437/…, tex.stackexchange.com/questions/94232/setting-math-font-size/… All good resources – Au101 Nov 28 '16 at 20:06
  • 2
    Well in that case, the best thing for you to do is rather than asking about the general case, give us an MWE which demonstrates your setup (all relevant packages, but none of the irrelevant ones ideally) and an equation to experiment with. Then it might be easier to find out why the generic methods aren't working for you and suggest the correct approach – Au101 Nov 28 '16 at 20:11
  • 3
    Whatever else you may do, remove the instruction \newcommand\Large{\@setfontsize\Large\@xviipt{22}} from the preamble. I can't possibly work; for one, \Large is already defined by LaTeX; hence, \newcommand\Large{...} must throw an error message. – Mico Nov 28 '16 at 20:45
  • 2
    @AlanTuring no \large$$1=2$$ would be large as well (but actually I see you only wanted to make a subterm large, in which case $$a=\mbox{\large$\sqrt{x}$}$$ would work as well. (but $$ is not latex syntax. – David Carlisle Nov 28 '16 at 20:53
  • 2
    @AlanTuring $$ ... $$ is a TeX command. It should not be used in LaTeX, there are many things wrong with it. The LaTeX shorthand is \[ ... \]. This is what you need to use. Note one immediate advantage, it's easy to see where it starts \[ and where it ends \]. If I am looking at your source code and I see $$ how do I know whether I am entering or leaving display math mode? – Au101 Nov 28 '16 at 20:56
3

You definitely not want to scale parts of the equation, but rather use the proper way of setting it.

By the way, why asking for Danish when the document appears to be in Italian?

\documentclass[a4paper]{report}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[italian]{babel}

\usepackage{amsmath}
\usepackage{graphicx}

\begin{document}

\chapter{Some examples}

\section{Bad example}

Ecco una formula composta male. Si agisce come prima, solo
che ora l'incognita è il tempo, e si scrive
\[
2P_0=\scalebox{2}{$e^{\frac{\ln(1.4)}{30}\ t^*}$}
\]
Ecco la stessa formula composta correttamente. Si agisce come
prima, solo che ora l'incognita è il tempo, e si scrive
\[
2P_0=\exp\biggl(\frac{\ln(1.4)}{30}t^*\biggr)
\]

\end{document}

Note that $$ should never be used in LaTeX. Using \large or \Large instead of \scalebox would not solve the main issue, even if they worked in math mode, which they don't.

enter image description here

If you insist on the exponential notation, you can type

\[
2P_0=e^{(\ln(1.4)/30)t^*}
\]

to get

enter image description here

Two story fractions in exponents should be avoided as long as possible.

  • Grazie!! Molto chiaro! Effettivamente volevo tenere l'esponenziale come "e". P.s. Complimenti per i pacchetti che hai creato e per il manuale! :O tanta stima – Henry Nov 28 '16 at 20:55
  • P.s. WHy $$ shall be never used? I learnt it from my thesis professor, years ago.. I thought t was cool! – Henry Nov 28 '16 at 20:55
  • 2
    @AlanTuring Why is \[ … \] preferable to $$? – egreg Nov 28 '16 at 20:56
  • @AlanTuring: From your thesis advisor? How many years ago? – GuM Nov 28 '16 at 22:12
4

You've shown us a lengthy preamble so far but no code that actually attempts to change the math font size.

Anyway, it is entirely possible to change the font sizes used in math mode, as the following MWE demonstrates.

enter image description here

\documentclass{report}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\newcommand\pyth{$a^2+b^2=c^2$}
\usepackage{amsmath,mathdesign}
\begin{document}
\obeylines
\pyth
\large\pyth
\Large\pyth
\LARGE\pyth
\huge\pyth
\Huge\pyth
\end{document}
  • Yeah but I don't want to create N newcommand for all the equations I have to write. Or am I missing something? – Henry Nov 28 '16 at 20:27
  • P.s. the math font size changer should be "scalebox" and I wrote it. And I read it comes from the graphicx package, which I use! – Henry Nov 28 '16 at 20:29
  • 1
    @AlanTuring - Yes, you are missing something: the purpose of the \pyth macro. It is certainly not necessary to define macros to contain the equations. You may verify that this assertion is true by replacing every instance of \pyth in the body of the text with $a^2+b^2=c^2$ -- or any other equation you care about... -- and recompiling the code. – Mico Nov 28 '16 at 20:33
  • Uhh! Going to try! I did not know that :D – Henry Nov 28 '16 at 20:34
  • 1
    @AlanTuring - "Nothing works" is rather unspecific. My MWE obviously does work. I assume you're doing "something else" and that this "something else" isn't working. Sadly, I'm no clairvoyant. Unless you tell us what you're actually doing, the likelihood that anyone will be able to offer specific and helpful advice is going to be negligibly small. – Mico Nov 28 '16 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.