1

I installed Kile and Texlive 2011.

I wrote a very simple test document:

\documentclass[11pt]{article}
\usepackage{xltxtra}
\setmainfont[Mapping=tex-text]{Linux Libertine}
\begin{document}
Русский: Числовые выражения

English: Number expressions
\end{document}

When I run $ xelatex myfile.tex from command line it is properly compiled to pdf file.

But when I try to build it from Kile, it throws an error File xltxtra.sty not found.

How should I configure Kile or Texlive installation, so things work properly? My OS is Ubuntu 11.10.

  • 3
    Have you set any environment variables in Kile? (See Configure-Kile => LaTeX => General). – Marco Daniel Nov 8 '11 at 16:43
  • 1
    @MarcoDaniel I didn't set any env variables in Kile, but your comment helped me to solve the problem. The problem was I put updates to PATH, MANPATH and INFOPATH variables into the ~/.bashrc file, but they should be put into a separate script in /etc/profile.d/ directory, because .bashrc is only executed by interactive shells. – Maxim Nov 9 '11 at 8:12
  • See [TeX Live with Kile in Ubuntu][1] [1]: tex.stackexchange.com/questions/31858/… on 32 bits use: i386-linux – Regis Santos Nov 10 '11 at 2:56
3

The OP installed TeX Live without automatic creation of symbolic links. In this case he must set set the path of TeX Live.

The problem is solved in the thread: tlmgr is not accessible after installing TeX Live 2011 on a Ubuntu system

You can also set the path in Kile.
Settings ==> Configure - Kile ==> LaTeX ==> General

Here a screen shot: enter image description here

Of course the first method is recommended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.