I am trying to compile an article using XeLaTeX. The article also contain a bibliography file, which I want to print inside the article, without citing any of the bib entry.

Please see below the complete tex code-

\usepackage{fontspec}                       %for loading fonts
\usepackage{xunicode,xltxtra,url,parskip}   %other packages for formatting
\usepackage[big]{layaureo}              %better formatting of the A4 page
\usepackage{supertabular}               %for Grades
\usepackage{titlesec}                   %custom \section

SmallCapsFont = Fontin-SmallCaps.otf,
BoldFont = Fontin-Bold.otf,
ItalicFont = Fontin-Italic.otf


\pagestyle{empty} % non-numbered pages

\font\fb=''[cmr10]'' %for use with \LaTeX command

\section{Section before Publications}
Section before Publications


\section{Section after Publications}
Section after Publications

To compile this code, I initially run XeLaTeX followed by BibTeX. The BibTeX reports following error-

Process started

This is BibTeX, Version 0.99d (TeX Live 2015) The top-level auxiliary file: sample.aux I found no \citation commands---while reading file sample.aux I found no \bibdata command---while reading file sample.aux I found no \bibstyle command---while reading file sample.aux (There were 3 error messages)

Process exited with error(s)

Below is the necessary detail-

  • Tex Live 2015
  • Texmaker 4.5

I don't see the bib entries in the generated article. What's wrong here?

  • 1
    What if you load biblatex with the backend=bibtex option i.e. \usepackage[backend=bibtex]{biblatex}? – Dai Bowen Nov 29 '16 at 16:03
  • @DaiBowen: Awesome. It works perfectly. Can you please write down it as an answer, also describing the cause of the error? – Ravi Joshi Nov 29 '16 at 16:21
  • Remove \font\fb=''[cmr10]'': it is syntactically wrong and is useless anyway. – egreg Nov 29 '16 at 17:05

The biblatex package has support for two backends for processing/extracting entries from the bib file, bibtex and biber although bibtex is only supported for a subset of the possible biblatex functions detailed in 3.14 Using the fallback BibTeX backend of the biblatex documentation.

By default the preferred backend of biber is expected when biblatex is loaded and thus different information is written to the aux file, incompatible with the necessary code for bibtex. In order to run bibtex with biblatex the package call must explicitly say that bibtex will be used by passing the backend=bibtex option to biblatex i.e. \usepackage[backend=bibtex]{biblatex} if no other options are called.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.