3

I am trying to use biblatex in beamer document class. There are some questions about customizing biblatex style and using biblatex in beamer. But I feel I can not find a complete answer to my question and I am trying to find an easy way to achieve my goal with your help. I want the reference to be shown in the foot line of current frame with only some key fields. And I am approaching there. Here is my code:

\documentclass{beamer}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Article{Bringa2012_NL.12.3351,
    author    = {Bringa, E. M. and Monk, J. D. and Caro, A. and Misra, A. and Zepeda-Ruiz, L. and Duchaineau, M. and Abraham, F. and Nastasi, M. and Picraux, S. T. and Wang, Y. Q. and Farkas, D.},
    title     = {Are Nanoporous Materials Radiation Resistant?},
    journal   = {Nano Letters},
    year      = {2012},
    volume    = {12},
    number    = {7},
    pages     = {3351-3355},
    note      = {PMID: 21651306},
    doi       = {10.1021/nl201383u},
    eprint    = {http://dx.doi.org/10.1021/nl201383u},
    file      = {:Are Nanoporous Materials Radiation Resistant_Nano Lett., 2012 12 (7) pp 3351–3355.pdf:PDF},
    groups    = {Nanowire irradiation, simulation},
    owner     = {Wenqiang},
    timestamp = {2014.09.22},
    url       = {http://dx.doi.org/10.1021/nl201383u},}
\end{filecontents}
\usepackage[backend=bibtex,style=verbose,url=false,isbn=false,eprint=false,doi=false]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}

\begin{frame}
  biblatex test\footnote{\cite{Bringa2012_NL.12.3351}}
  biblatex test\footcite{Bringa2012_NL.12.3351}
  biblatex test\footfullcite{Bringa2012_NL.12.3351}
\end{frame}

\end{document}

The result

However, two more modification needed. I can turnoff fields like url, doi etc. by using url=false,isbn=false,eprint=false,doi=false, but the 'PMID' and 'title' are still there and I found it hard to be modified. Is there any simple way like setting boolean values to turnoff these fields? And it is much better if the word In: can be turned off easily. I am using \footnote, \footcite and \footfullcite to get the same effect, if there any possible better method exists, please advise me.

Any help would be much appreciated!

12
  • 1
    \AtEveryCitekey{\clearfield{title} \clearfield{note}} \renewbibmacro{in:}{}. This could be tweaked for different entry types. But this has to be a duplicate for both questions.
    – jon
    Commented Dec 1, 2016 at 3:44
  • Thank you really very much! That is exactly what I want. I did not find a similar answer before, I am very sorry for that. Now, I got some thing like E. M. Bringa et al. Nano Letters 12.7 (2012), pp.3351-3355. I still want one minor change. Could please tell me is that possible to get rid of , and pp before the page numbers?
    – mgqqlwq
    Commented Dec 1, 2016 at 8:04
  • Comma: \renewcommand*{\bibpagespunct}{\addspace}; 'pp.': \DeclareFieldFormat{postnote}{#1}. (Note that these can have pretty global effects.)
    – jon
    Commented Dec 1, 2016 at 18:51
  • 4
    I'm voting to close this question as off-topic because solved in comments Commented Dec 6, 2016 at 16:46
  • 1
    @jon Do you have any suggestion what to do with the question now it is reopened? Do you have any 'favourite' among the duplicates you found, or do you just want to give your comment as an official answer below?
    – moewe
    Commented Dec 9, 2016 at 14:55

1 Answer 1

4

Four changes are requested in the question. These have been answered before (probably more than once in some cases).

  1. Remove the title and note fields in citations. One solution is to use:

    \AtEveryCitekey{\clearfield{title} \clearfield{note}}
    

    See https://tex.stackexchange.com/a/303387/8528 for more information.

  2. Remove the 'in:' in citations. One solution is to do:

    \renewbibmacro{in:}{}
    

    See https://tex.stackexchange.com/a/10686/8528 for more information

  3. (a) Modifying the postnote field so it doesn't print a comma and (b) inhibit the appearance of pp.. One solution is to do:

    \renewcommand*{\bibpagespunct}{\addspace}% remove comma
    \DeclareFieldFormat{postnote}{#1}%         not print p./pp.
    

    See https://tex.stackexchange.com/a/300985/8528 for more information.

3
  • CW because not an original answer, and because people can substitute better links if they know/find them.
    – jon
    Commented Dec 10, 2016 at 17:23
  • I found a problem that \AtEveryBibitem{\clearfield{language}} seems can not turnoff the field language in bibliography items. I think it is closely related to my previous question. Should I modify my original question above or open a new one? Please advise me. Thanks very much!
    – mgqqlwq
    Commented Jan 22, 2017 at 1:58
  • Best to ask a new question and link back to this question if need be.
    – jon
    Commented Jan 22, 2017 at 3:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .