1

This thread explains how to edit Texshop's autocomplete file. I have two problems with this file:

  1. It contains Gibrish letters, even after changing the encoding to utf8 (screenshots below).
  2. I can see there some auto-completion rules that do not work when I edit. For example, It looks like when typing ^ and then pressing Esc, this should be replaced with ^{}. But this is not the case.

How can I fix these issues?

GIBRISH

preferences screen

2
  • Might be helpful if you took a screen shot so that we can see what the_ Gibrish_ characters look like. Dec 2, 2016 at 7:33
  • "See the complete documentation, with lists of commands/abbreviations supplied with TEXShop out of the box, in the ~/Library/ TeXShop/CommandCompletion/ folder for much more information."
    – Michael E2
    Jul 13, 2019 at 18:04

1 Answer 1

1

Regarding 2., you have to enable the autocompletion in the texshop options

6
  • Where do you have to enable it from? I only see the option to select "Command Completion Triggered By" either "Escape Key" or "Tab Key" in version 3.75 (which is the latest as of today). Dec 2, 2016 at 7:34
  • I've also added a screen shot of the preferences screen.
    – Yoni Zohar
    Dec 2, 2016 at 9:48
  • From the menu - Source - autocompletion - Enable/disable
    – Francesco
    Dec 2, 2016 at 10:23
  • 1
    I don't have this. However, I do have Source - Command Completion - Edit Command Completion File. This opens a file named CommandCompletion.txt, that does not include explanations. Now, when I add e.g. ^:=^{#INS#}, it auto completes ^ only when it does not have anything before it. So for example if I am writing $x^ and then press Esc, it does nothing. I am using ver. 3.75.
    – Yoni Zohar
    Dec 2, 2016 at 16:20
  • 1
    The key bindings seem to relate to something else. Also, it seems to me that the command completion is actually enabled, just that in this specific example, it doesn't act as I would expect.
    – Yoni Zohar
    Dec 2, 2016 at 23:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .