5

I am compiling a document using XeLaTeX, and I am seeing the following warning message:

xdvipdfmx:warning: Object @page.1 already defined.

I'm not sure what would be causing it/how to resolve it?

I'm using MiKTeX on Win 7 (64-bit) and the version of xdvipdfmx is listed as:

This is xdvipdfmx Version 20160619 by the DVIPDFMx project team,
modified for TeX Live and MiKTeX,
  • Welcome to TeX.SX! Hard to analyze your problem without seeing the code. Do you have two pages with the same page number 1? If not, then please add the compilable code of a small document to your posting. If yes, it might be enough to number them in different styles (e.g. roman vs arabic); usually one wants to avoid duplicate page numbers anyway. – gernot Dec 2 '16 at 14:33
  • Try deleting the aux file (clean project for Texnic). – John Kormylo Dec 3 '16 at 5:55
4

Thanks to gernot for the suggestion to look at the page numbering - it turned out that my title page was being assigned as "Page 1" even though \pagestyle{empty} was being used for that page to suppress the page number being displayed. This then conflicted with the "Page 1" in the main matter (which uses \pagestyle{plain}), resulting in the warning message above.

Setting \pagenumbering{gobble} for the title page (as per this answer) solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.